Problème de calcul sur menu déroulant

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
ZOZO6234
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 8 mai 2019
Version d'Excel : 2016

Message par ZOZO6234 » 8 mai 2019, 19:34

feuille de calcul matériel auto.xlsx
(11.28 Kio) Téléchargé 3 fois
feuille de calcul matériel auto.xlsx
(11.28 Kio) Téléchargé 3 fois
Bonsoir à toutes et tous .

Je suis en trin de réaliser un fichier Excel affin de comme tout le monde me facilitée la vie dans le futur mais qui actuellement me ronge depuis prés de 3 heures .

Dans un premier temp merci a vous toutes et tous pour les divers solution que j'ai pu trouver via votre forum mais la je suis vraiment en galère et je ne trouve pas voila pourquoi je me permet de poster .

Alors mon fichier est en 2 feuilles

Sur la Feuille 1"récapitulatif de câble" de D5 à D53 j'ai insérer un menu déroulant reprenant 3 catégorie "Sout, Aéro, Aéro-Sout" et je souhaiterai que sur ma feuille 02 " liste de matériel à commander " dans ma cellule B20 je souhaiterai que si "Aéro-Sout" soit sélectionné donc de D5 à D53 sur la feuille 1 sa me donne la quantité de 3 moulure à chaque fois .
J'ai donc insérer cette formule =SI(Feuil1!D5:D53="Aéro-Sout";3;0) mais impossible a passer mais par contre si je selectionne uniquement =SI(Feuil1!D5="Aéro-Sout";3;0) la j'ai mon nombre de 3 qui s'affiche dans ma cellule.

Alors soit je me complique trop la vie ou je fait une erreur sur un signe ;:,! ou autre.

D'avance un grand merci pour votre aide .

Jonathan
Avatar du membre
ZOZO6234
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 8 mai 2019
Version d'Excel : 2016

Message par ZOZO6234 » 8 mai 2019, 20:05

Re bonsoir,

Je pense avoir réussi mon problème en y insérant cette formule :
=NB.SI(Feuil1!D5:D53;"Aéro-Sout")*3

Je ne sais pas si celle ci est vraiment la bonne mais ça à l'air de fonctionner .

Encore merci a tous pour ce que vous faites .

Bonne soirée
Avatar du membre
ZOZO6234
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 8 mai 2019
Version d'Excel : 2016

Message par ZOZO6234 » 8 mai 2019, 20:47

En fait je suis encore désolé mais j'ai oublier un petit point :(

Alors en fait dans la catégorie moulure j'ai une deuxième entre de calcul qui doit si mettre .
En gros je dois donc avoir la somme de Feuil1 tous les D avec en sélection aéro sout *3 moulure et je dois rajouter la somme de H5 à H53 + I5 à I53 *1 et c'est la que ça ce complique car rien ne ce calcul je n'arrive pas a insérer 2 commandes dans la même cellules . De ce fait j'ai fait une modif sur ma feuille 2 j'ai donc mit en formule dans Feuil2! C20 =SOMME(Feuil1!H5:I52) et en C21 =SOMME(B20+C20) .

Pensez vous qu'il y aurai une façon possible de combiné ces formules dans la même cellule ?

D'avance merci et pardon de remonter le post je penser avoir réussi a me débrouiller seul mais n'est pas expert qui veut ;;)

Ps: je vous ai mit le fichier avec la dernière modif en PJ
feuille de calcul matériel auto.xlsx
(11.38 Kio) Téléchargé 2 fois
j
jmd
Fanatique d'Excel
Fanatique d'Excel
Messages : 10'616
Appréciations reçues : 251
Inscrit le : 8 décembre 2007
Version d'Excel : 365 + PowerBI

Message par jmd » 9 mai 2019, 09:13

bonjour

pour ton premier onglet, il faut absolument lire et appliquer ceci
https://www.google.com/url?sa=t&rct=j&q ... MpGI3dFElo

ensuite, il faudrait dire à quoi sert ton fichier (gestion de stocks, autre ? )

à te relire
amitiés
1 membre du forum aime ce message.
Apprenez les fonctions d'Excel.
Exemple "Mettre sous forme de tableau", TCD, "Récupérer des données".
Apprendre les fonctionnalités "récentes".
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message