Afficher des intervalles

Bonjour,

Je coince en ce moment avec mon impossibilité d'afficher des intervalles. Je m'explique:

Dans le fichier exemple que je mets en PJ, je souhaite faire apparaître le premier numéro de pièce d'une série de numéro qui se suivent ainsi que le dernier. Pour pouvoir extraire les intervalles. Exemple

Col 1 Col 2 Col 3

124 124 127

125 132 134

126 141 141 (ou rien)

127 145 146

132

133

134

141

145

146

Dans le fichier exemple vous trouverez une série de numéro de pièce extraite sous le format texte (que je n'arrive pas à transformer en nombre ou standard même en modifier les formats dans l'onglet prévu à cet effet, je suis obligé de double cliquer dans chaque cellule et d'appuyer sur entrée après avoir modifier le format, impossible de prendre le temps pour 1000 numéros ...) et le premier essai que j'ai réalisé avec ses ratés.

J'ai rajouté un grand nombre de numéro de pièce, les plages de cellules ne sont plus correctes.

Pouvez-vous m'aiguiller dans la bonne direction ?

Bien cordialement,

5intervalles.xlsx (20.96 Ko)

Bonjour

A tester

=SI($B$2:$B$66=D2;MIN(($A$2:$A$66)*1);"")

Bonjour

A tester

=SI($B$2:$B$66=D2;MIN(($A$2:$A$66)*1);"")

Je ne suis pas certain que cela fasse avancer mon problème, à moins de ne pas bien comprendre.

Je poste une version mise à jour, je ne sais pas comment intégrer dans la formule le fait que si le numéro d'intervalle est unique en colonne B (ce qui veut dire que le numéro de pièce ne suit pas un autre et n'est pas suivi) alors qu'il inscrive en début et fin d'intervalle ce même numéro de pièce.

Exemple en intervalle numéro 10 dans le fichier en PJ.

5intervalles.xlsx (41.06 Ko)

Bonjour,

je ne vois pas trop le lien entre tes explications qui annoncent 3 colonnes et le fichier que tu fournis.

Plutôt qu'une formule manifestement fausse, met le résultat attendu en expliquant le pourquoi et le comment.

eric

Bonjour,

je ne vois pas trop le lien entre tes explications qui annoncent 3 colonnes et le fichier que tu fournis.

eric

Ce n'était qu'un exemple d'illustration, le fichier fourni fait foi. C'était une manière d'expliquer le problème avant d'avoir à ouvrir le fichier, mais il ne faut tenir compte que de ce dernier.

J'ai édité mon post, relis.

Ah, je crois avoir compris ce que tu veux.

En E1 :

=INDEX(A:A;EQUIV(D2;B:B;0))

en F1 :

=INDEX(A:A;EQUIV(D2;B:B;0)+NB.SI(B:B;D2)-1)

eric

Ah, je crois avoir compris ce que tu veux.

En E1 :

=INDEX(A:A;EQUIV(D2;B:B;0))

en F1 :

=INDEX(A:A;EQUIV(D2;B:B;0)+NB.SI(B:B;D2)-1)

eric

C'était exactement ça merci.

Très bonne journée.

Rechercher des sujets similaires à "afficher intervalles"