Somme d'une plage en valeur absolue et différent de texte Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
M
MaxBRD1
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 12 avril 2019
Version d'Excel : 2016 FR

Message par MaxBRD1 » 12 avril 2019, 12:21

Bonjour à tous,

J'aurais besoin de votre aide sur une formule.

J'ai une colonne contenant des valeurs positives comme négatives, mais aussi du texte ("P?" et "H?").

J'aimerais déterminer la somme de celle-ci en valeur absolue afin d'éviter les phénomènes de compensation, mais aussi en excluant tout type de texte (car il se peut qu'il y ait d'autres types de texte à l'avenir).

J'ai essayé avec :
- =SOMMEPROD(ABS(Ma_plage)) : elle marche, mais seulement quand la colonne ne contient pas de texte. D'ailleurs, ABS marche sur la plage, étonnant, car normalement il me semble qu'on ne peut pas l'utiliser sur une plage mais seulement sur une valeur non ? ;
- =SOMME.SI(Ma_plage;ET("<>P?";"<>H?");Ma_plage) : cela fait une somme en excluant le texte que j'ai (à savoir "P?" et "H?"), mais pas tout type de texte. Ma solution => =SOMME.SI(A2:A6;"<>*";A2:A6), l'étoile marche même entre guillemets dans ce cas-là nous sommes d'accord ?
- =SOMME.SI(Ma_plage;ET("<>P?";"<>H?");ABS(Ma_plage)) : Même résultat, mais la formule permettant de mettre en valeur absolue la plage ne marche pas cette fois-ci.

Voici un fichier en pièce jointe.

Je vous remercie par avance pour votre aide.

Bien cordialement,
Excel pratique forum - somme en valeurs absolues si différent d'un texte quelconque.xlsx
(11.69 Kio) Téléchargé 5 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'386
Appréciations reçues : 244
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 12 avril 2019, 12:59

Bonjour le forum,
=SOMME.SI(A1:A6;">=0";A1:A6)+-(SOMME.SI(A1:A6;"<0";A1:A6))
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 13'577
Appréciations reçues : 756
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 12 avril 2019, 13:00

Bonjour,

formule matricielle
=SOMME(SI(ESTNUM(A2:A6);ABS(A2:A6);0))
Excel pratique forum - somme en valeurs absolues si différent d'un texte quelconque.xlsx
(11.22 Kio) Téléchargé 2 fois

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
M
MaxBRD1
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 12 avril 2019
Version d'Excel : 2016 FR

Message par MaxBRD1 » 12 avril 2019, 13:28

Merci beaucoup à @mbbp !

Merveilleux ! 8[] ::D ::D

@Steelson, ta formule ne marche pas... ESTNUM n'a l'air de marcher que sur une cellule, et non sur une plage et, de plus, elle te renvoie VRAI ou FAUX, aucun de tes arguments ne traitent du VRAI ou FAUX.
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 13'577
Appréciations reçues : 756
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 12 avril 2019, 15:42

MaxBRD1 a écrit :
12 avril 2019, 13:28
@Steelson, ta formule ne marche pas... ESTNUM n'a l'air de marcher que sur une cellule, et non sur une plage et, de plus, elle te renvoie VRAI ou FAUX, aucun de tes arguments ne traitent du VRAI ou FAUX.
Merci de tes encouragements mon cher et bravo pour ton assurance ... surtout que tu n'as pas encore chargé mon fichier qui te démontre que cela fonctionne !
Capture d’écran (674).png

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message