Ajouter un caractère selon critères Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
O
Obeida
Membre habitué
Membre habitué
Messages : 109
Appréciations reçues : 2
Inscrit le : 2 novembre 2017
Version d'Excel : 2013 FR

Message par Obeida » 11 avril 2019, 10:55

Bonjour,

J'ai une liste avec des nombres allant de deux à cinq chiffres. Je voudrais que tous les nombres en dessous de 4 chiffres aient les caractères suivants les précédant : " '0 " si un trois chiffres, " '00 " si deux chiffres.

Pour mes besoins, les chiffres dans cette liste doivent obligatoirement être sous la forme de quatre caractères. Ce qui veut dire que si j'ai un chiffre avec deux ou trois caractères, cela ne marchera pas.

Voici un exemple en fichier (en rouge les cases qui doivent changer, en vert celles qui restent intactes).

Merci d'avance.
TEST.xlsx
(12.39 Kio) Téléchargé 6 fois
Avatar du membre
M12
Membre impliqué
Membre impliqué
Messages : 2'687
Appréciations reçues : 73
Inscrit le : 3 juillet 2015
Version d'Excel : 2013

Message par M12 » 11 avril 2019, 10:59

Bonjour,

Sélection de la colonne qui doit être formatée
Clic droit --> Format de cellule --> Personnalisée
dans le TYPE, mettre 4 zéros --> 0000
validez par OK
Merci de clôturer le fil en cliquant sur le bouton V vert du post à coté du bouton EDITER si problème résolu

Je ne répond pas au message privé
O
Obeida
Membre habitué
Membre habitué
Messages : 109
Appréciations reçues : 2
Inscrit le : 2 novembre 2017
Version d'Excel : 2013 FR

Message par Obeida » 11 avril 2019, 11:01

M12 a écrit :
11 avril 2019, 10:59
Bonjour,

Sélection de la colonne qui doit être formatée
Clic droit --> Format de cellule --> Personnalisée
dans le TYPE, mettre 4 zéros --> 0000
validez par OK
Bonjour M12,

Merci pour ta réponse mais lorsque je fais cela, les cellules sont certes implémentés du nombre de caractère qu'il faut, mais moi j'ai besoin d'ajouter explicitement un apostrophe et un zéro pour trois chiffres, un apostrophe et deux zéros pour deux chiffres etc.
Avatar du membre
Pedro22
Membre impliqué
Membre impliqué
Messages : 2'542
Appréciations reçues : 255
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 11 avril 2019, 15:59

Bonjour, salut M12,

Une proposition de formule à ajouter en B2 :
=SI(NBCAR(A2)<4;""&REPT(0;4-NBCAR(A2))&A2;A2)
J'ai pris le parti de ne pas mettre le caractère ' car il apparaît à l'écran et n'est pas utile tant que le résultat est stocké au format texte. S'il doit être ajouté, son emplacement est prévu entre les guillemets dans la formule.
Le problème n'est pas de ne pas savoir, le problème est de ne pas chercher...
Ton problème est résolu ? N'oublie pas de l'indiquer :
O
Obeida
Membre habitué
Membre habitué
Messages : 109
Appréciations reçues : 2
Inscrit le : 2 novembre 2017
Version d'Excel : 2013 FR

Message par Obeida » 11 avril 2019, 16:04

Pedro22 a écrit :
11 avril 2019, 15:59
Bonjour, salut M12,

Une proposition de formule à ajouter en B2 :
=SI(NBCAR(A2)<4;""&REPT(0;4-NBCAR(A2))&A2;A2)
J'ai pris le parti de ne pas mettre le caractère ' car il apparaît à l'écran et n'est pas utile tant que le résultat est stocké au format texte. S'il doit être ajouté, son emplacement est prévu entre les guillemets dans la formule.
Merci @Pedro22,

c'est ce que je voulais.

Bonne fin de journée
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message