Vérification valeurs entre deux colonnes puis copie valeur colonne associée

Y compris Power BI, Power Query et toute autre question en lien avec Excel
c
caps01
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 7 mars 2019
Version d'Excel : 2016 FR
Version de Calc : 6.1.4 FR

Message par caps01 » 7 mars 2019, 08:07

Bonjour à tous,

Mon tableau est constitué de 5 colonnes avec X lignes.

Colonne A: libellés
Colonne B: code associé au libellé
Ces deux colonnes sont ma base de travail

Colonne C: non utilisée, simple séparateur

Colonne D: libellés en partie présent dans la colonne A
Colonne E: code associé au libellé (= code de la colonne B)

Je cherche donc à vérifier que l'information texte contenue dans ma colonne A correspond à celle de ma colonne D.
Une fois la vérification faite, je veux prendre la valeur contenue dans la colonne B (associé à mon libellé colonne A) et la copier sur la ligne du libellé équivalent dans ma colonne E.

Je joins un fichier pour imager...
transcod.xlsx
(8.9 Kio) Téléchargé 4 fois
Merci d'avance :-)
Romain
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 7 mars 2019, 09:12

Bonjour le forum,

E1 :
=SIERREUR(RECHERCHEV(D1;$A$1:$B$100;2;0);"")
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'300
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 7 mars 2019, 09:15

Re,

Ou :
=SIERREUR(INDEX(B:B;EQUIV(D1;A:A;0));"")
c
caps01
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 7 mars 2019
Version d'Excel : 2016 FR
Version de Calc : 6.1.4 FR

Message par caps01 » 7 mars 2019, 23:23

Bonsoir merci!

Je test dès que possible là je sors du taf ... Au lit

Je te tiens rapidement informé
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message