Excel calcul jours d'absences avec date et heure fixe

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
M
MOINLY
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 17 mars 2007

Message par MOINLY » 30 janvier 2019, 16:51

Bonjour,

Je souhaiterai trouver la formule pour calculer le nombre de jours d'absences pour des congés,

Exemple :

Je suis absent du 01/01/2019 à ma fin de travail qui est à 17H00 et je reprends le 03/01/2019 à 8H00,

Le nombre de jour d'absence doit être de 1.

Je joins un fichier pour exemple.
Congés.xls
(32 Kio) Téléchargé 35 fois
Avatar du membre
lauange
Membre fidèle
Membre fidèle
Messages : 235
Appréciation reçue : 1
Inscrit le : 2 février 2016
Version d'Excel : 2013FR

Message par lauange » 30 janvier 2019, 18:39

Salut,

Remplace ta formule de calcul par : =SI(D3*24>=17;JOUR(H3-B3)-1;JOUR(H3-B3))
Excel 2013 windows et Excel 2016 Mac OSX
M
MOINLY
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 17 mars 2007

Message par MOINLY » 30 janvier 2019, 19:05

Merci lauange,

Ta formule fonctionne super bien,

Je souhaiterai également rajouter un autre détail,

Je m'explique :

Si je finis le travail le 01/01/2019 à 17H00 et que je reprends le travail le 02/01/2019 à 13H00,

Je devrai avoir comme jour d'absence : 0,5

Car je n'aurai pris que la matinée.

Merci par avance.
M
MOINLY
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 17 mars 2007

Message par MOINLY » 31 janvier 2019, 20:24

quelqu'un aurait une solution ?
Avatar du membre
AMIR
Membre dévoué
Membre dévoué
Messages : 748
Appréciations reçues : 7
Inscrit le : 19 janvier 2015
Version d'Excel : 2007

Message par AMIR » 31 janvier 2019, 22:00

Salut MOINLY
essai ça
Congés.xls
(36 Kio) Téléchargé 32 fois
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 14'980
Appréciations reçues : 881
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 1 février 2019, 01:11

Bonjour à tous ...

avec prise en compte des jours fériés
=NB.JOURS.OUVRES(A1;B1;'jours fériés'!C:C)-2+SI(MOD(B1;1)>deb;0,5;0)+SI(MOD(A1;1)<fin;0,5;0)
congés.xlsx
(12.82 Kio) Téléchargé 21 fois

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
M
MOINLY
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 17 mars 2007

Message par MOINLY » 1 février 2019, 18:45

Bonjour à tous,

Merci encore pour votre aide !
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message