SI cellule contient texte quelconque alors... Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
789_excel
Nouveau venu
Nouveau venu
Messages : 8
Inscrit le : 14 septembre 2010
Version d'Excel : 2016

Message par 789_excel » 19 janvier 2019, 15:48

Bonjour,
Question d'un néophyte.
Tout est expliqué dans le fichier excel joint.
Merci d'avance
TestCantons.xlsx
(10.61 Kio) Téléchargé 96 fois
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 14'062
Appréciations reçues : 832
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 19 janvier 2019, 16:23

Bonjour la Suisse,

Attention, une formule ne peut pas se mettre (sauf VBA) à la place d'une valeur existante ... j'ai donc ajouté une colonne.
Si tu tries la colonne 1 selon tes critères, mais aussi la colonne 2 de A à Z, alors tu as cette formule :
=SI(B2="";INDEX(B:B;EQUIV(A2;A:A;0));B2)
Maintenant on peut aussi le faire en VBA (et sans avoir besoin de trier la colonne 2)
TestCantons.xlsx
(10.88 Kio) Téléchargé 33 fois

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'910
Appréciations reçues : 693
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 19 janvier 2019, 17:11

Bonjour 789_excel, Steelson,

:bv:

je te retourne ton fichier modifié :
TestCantons.xlsm
(16.95 Kio) Téléchargé 82 fois
Ctrl e ➯ travail effectué !  :)

Alt F11 pour voir le code VBA, puis revenir sur Excel

si besoin, tu peux demander une adaptation.
merci de me dire si ça te convient.

dhany  Image
Avatar du membre
789_excel
Nouveau venu
Nouveau venu
Messages : 8
Inscrit le : 14 septembre 2010
Version d'Excel : 2016

Message par 789_excel » 19 janvier 2019, 17:50

Re-bonjour,

Ben ça alors! Y'a vraiment des personnes douées!
Ça fonctionne nickel.
Mille fois merci.
:sp: :appl2:
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'910
Appréciations reçues : 693
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 19 janvier 2019, 19:04

j'étais en pause, et j'viens d'lire ton post.

merci pour ton retour, et pour avoir passé le sujet en résolu !  :D

bonne continuation !  :trfl:

dhany
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message