Affichage de la dernière valeur renseignée ?

Y compris Power BI, Power Query et toute autre question en lien avec Excel
J
JEROME29
Jeune membre
Jeune membre
Messages : 21
Inscrit le : 29 mai 2009
Version d'Excel : 2000

Message par JEROME29 » 12 juin 2009, 12:54

Bonjour,

Je souhaiterais afficher dans une case A10 la valeur de la dernière case de la même ligne renseignée.

Exemple :
A1 A2 A3 A4 A5 A6 A7 A8 A9 A10
25 13 19 19

Dans cet exemple c'est 19 qui doit être en A10
et si je rajoute une valeur en A4, cette même valeur doit se positionner en A10
Avatar du membre
Sylvain TBM
Membre dévoué
Membre dévoué
Messages : 538
Inscrit le : 11 juin 2008
Version d'Excel : 2003 FR

Message par Sylvain TBM » 12 juin 2009, 13:27

Bonjour,

Si tu n'as que des chiffres la formule en A10 :
=RECHERCHE(9^9;$A$1:$A$9)
Il vaut mieux 10 qui savent que 1 qui cherche....
J
JEROME29
Jeune membre
Jeune membre
Messages : 21
Inscrit le : 29 mai 2009
Version d'Excel : 2000

Message par JEROME29 » 12 juin 2009, 13:42

c'est pas mal du tout. merci.

Et comment faire pour afficher 0 si aucune valeur renseignée ?
N
Nad-Dan
Passionné d'Excel
Passionné d'Excel
Messages : 7'257
Inscrit le : 27 avril 2007
Version d'Excel : 2003 FR-2007 FR-MAC 2004 FR

Message par Nad-Dan » 12 juin 2009, 14:03

Bonjour,

Tu peux mettre une condition d'erreur dans la formule de Sylvain comme ceci :
=SI(ESTERREUR(RECHERCHE(9^9;$A$1:$A$9));;RECHERCHE(9^9;$A$1:$A$9))
ou formule qui marchera aussi:
=DECALER($A$1;NBVAL(INDIRECT("A2:A" & LIGNE()-1));;)
A placer où tu veux dans ta colonne A.
Amicalement

Dan
Avatar du membre
Sylvain TBM
Membre dévoué
Membre dévoué
Messages : 538
Inscrit le : 11 juin 2008
Version d'Excel : 2003 FR

Message par Sylvain TBM » 12 juin 2009, 14:54

Salut Dan,

Mon premier réflexe avait aussi été DECALER :wink:

Mais je me suis dit que s'il y a des cellules vides qui trainent ça ne marche plus... :roll:

Donc Jérôme attention : tu peux utiliser la formule de Dan seulement si tu n'a pas de cellule vide avant ta dernière valeur
Il vaut mieux 10 qui savent que 1 qui cherche....
N
Nad-Dan
Passionné d'Excel
Passionné d'Excel
Messages : 7'257
Inscrit le : 27 avril 2007
Version d'Excel : 2003 FR-2007 FR-MAC 2004 FR

Message par Nad-Dan » 12 juin 2009, 15:24

Bonjour

Autres formules :
=SI(NBVAL($A$1:$A$9)>0;RECHERCHE(9^9;$A$1:$A$9);0)
Amicalement
Nad
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message