Formule si cellule contient un texte

Y compris Power BI, Power Query et toute autre question en lien avec Excel
m
moon-ia
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 7 janvier 2019
Version d'Excel : MAC 2018 FR

Message par moon-ia » 7 janvier 2019, 20:56

Bonjour,

Je voudrais retrouver un formule qui me permette de détecter s'il y a un texte dans une cellule.

Par exemple, la cellule contient :
10/12/2018 JAREDLETO PARIS/LESAUBRAIS

Et je voudrais ressortir dans une cellule "Paris"; tout en sachant que mes cellules n'ont pas le même format, et donc je ne peux pas mettre une formule qui lis à partir d'un certain nombre de caractères. Mes données sont hétérogènes, et je les retraite manuellement...

J'ai vraiment vraiment besoin de votre aide!
Merci d'avance.
Avatar du membre
LouReeD
Contributeur
Contributeur
Messages : 6'664
Appréciations reçues : 321
Inscrit le : 14 octobre 2014
Version d'Excel : 2013 FR, 2016 FR
Contact :
Téléchargements : Mes applications

Message par LouReeD » 7 janvier 2019, 21:04

Bonsoir,

par contre si votre recherche est "toujours" faite sur Paris, alors vous pouvez utilisez TROUVE :
texte en A1, test en B1=SI(ESTERREUR(TROUVE("Paris";A1;1));"il n'y a pas Paris !";"Paris")

Attention TROUVE "respecte" la casse !

@ bientôt

LouReeD
Quelques règles à lire ICI ;;)
______________________________________________________Vous pouvez allez faire un tour sur : Index de "Mes applications" ;;)
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'659
Appréciations reçues : 237
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 7 janvier 2019, 21:09

bonjour
par exemple
la fonction est matricielle
moonnia.xlsx
(8.71 Kio) Téléchargé 19 fois
cordialement
c'est en cherchant qu'on trouve
A
Andre13
Membre impliqué
Membre impliqué
Messages : 1'678
Appréciations reçues : 109
Inscrit le : 13 juillet 2017
Version d'Excel : 2007-2013

Message par Andre13 » 7 janvier 2019, 21:16

Bonjour toutes et tous,

coucou Loureed et Tulipe ;;)

@ tester:
ci-joint
crdlt,
André
image
image
z60.png (15.85 Kio) Vu 607 fois
Cherche_test001.xlsx
classeur Excel
(10.81 Kio) Téléchargé 13 fois
Avatar du membre
LouReeD
Contributeur
Contributeur
Messages : 6'664
Appréciations reçues : 321
Inscrit le : 14 octobre 2014
Version d'Excel : 2013 FR, 2016 FR
Contact :
Téléchargements : Mes applications

Message par LouReeD » 7 janvier 2019, 21:25

tulipe_4 !
Vous êtes trop fort ! :lol:

en ligne 4 de votre fichier si vous effacez "lyon" alors votre formule trouve que la capitale est "Paris" ! :P

@ bientôt

LouReeD
Quelques règles à lire ICI ;;)
______________________________________________________Vous pouvez allez faire un tour sur : Index de "Mes applications" ;;)
m
moon-ia
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 7 janvier 2019
Version d'Excel : MAC 2018 FR

Message par moon-ia » 7 janvier 2019, 21:31

Bonsoir,

Justement, ma recherche n'est pas faite que sur Paris. Le texte peut contenir "Orléans", "Les aubrais", "Paris aus"; "Madrid"; "Dubai" etc.
Mon objectif est de ressortir dans une cellule s'il s'agit d'un déplacement à Paris, en France, en Europe ou dans le reste du monde; par rapport des données textes (et numériques) hétérogènes.
Si "mon texte extrait" contient ou("Paris";"Orléans";"Les aubrais") alors "Paris"
Si "mon texte extrait" contient ou("Madrid";"Istanbul";"Lisbonne") alors "Europe"
...
C'est un peu la vision que j'ai. En espérant avoir été plus claire.
Et merci pour le retour!
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'659
Appréciations reçues : 237
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 7 janvier 2019, 21:36

re
salut LOU
bon d'accord , c'était pour eviter d'errer sans but 8[] :lol:
=SI(MAX(SI(ESTNUM(CHERCHE(L$2:L$6;B4));LIGNE($1:$5);""))=0;"";INDEX(L$2:L$6;MAX(SI(ESTNUM(CHERCHE(L$2:L$6;B4));LIGNE($1:$5);""))))
c'est mieux
c'est en cherchant qu'on trouve
Avatar du membre
LouReeD
Contributeur
Contributeur
Messages : 6'664
Appréciations reçues : 321
Inscrit le : 14 octobre 2014
Version d'Excel : 2013 FR, 2016 FR
Contact :
Téléchargements : Mes applications

Message par LouReeD » 7 janvier 2019, 21:37

Alors regardez le messages de tulipe_4 ! :-)

Car dans tous les cas il faut bien une base de référence, non ?

@ bientôt

LouReeD
Quelques règles à lire ICI ;;)
______________________________________________________Vous pouvez allez faire un tour sur : Index de "Mes applications" ;;)
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'659
Appréciations reçues : 237
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 7 janvier 2019, 21:44

LouReeD a écrit :
7 janvier 2019, 21:37
Alors regardez le messages de tulipe_4 ! :-)

Car dans tous les cas il faut bien une base de référence, non ?

@ bientôt

LouReeD
auquel cas il faudait remplacer CHERCHE par TROUVE et bien entendu la fameuse base de ref ou alors il faut que les lieux ciblés soient en majuscule et rien qu'eux
c'est en cherchant qu'on trouve
m
moon-ia
Nouveau venu
Nouveau venu
Messages : 4
Inscrit le : 7 janvier 2019
Version d'Excel : MAC 2018 FR

Message par moon-ia » 7 janvier 2019, 21:50

tulipe_4 a écrit :
7 janvier 2019, 21:44
LouReeD a écrit :
7 janvier 2019, 21:37
Alors regardez le messages de tulipe_4 ! :-)

Car dans tous les cas il faut bien une base de référence, non ?

@ bientôt

LouReeD
auquel cas il faudait remplacer CHERCHE par TROUVE et bien entendu la fameuse base de ref ou alors il faut que les lieux ciblés soient en majuscule et rien qu'eux
Mais dans ma base de données, je ne retrouve pas que les lieux, et ils ne sont pas toujours en majuscule. Que faire?

J'ai mis en PJ un extrait de ma BDD.
bdd.xlsx
(8.72 Kio) Téléchargé 13 fois
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message