Somme de valeur avec case spécifique

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
f
fizik
Jeune membre
Jeune membre
Messages : 33
Inscrit le : 2 mars 2017
Version d'Excel : Google Sheets

Message par fizik » 5 janvier 2019, 21:48

Bonjour,

J'ai un petit soucis.
J'aimerais avoir une somme des valeurs de la colonne B quand sur la même ligne sur la colonne A il y a une valeur précise, par exemple : Jean.

Je suppose qu'il faut que j'utilise un SUM couplé avec un COUNTIF n'est-ce pas ?

Merci d'avance
calc1.xlsx
(8.22 Kio) Téléchargé 5 fois
Avatar du membre
i20100
Passionné d'Excel
Passionné d'Excel
Messages : 6'030
Appréciations reçues : 351
Inscrit le : 16 mars 2017
Version d'Excel : 2010

Message par i20100 » 5 janvier 2019, 22:08

Bonjour,

voici une possibilité avec SOMMEPROD
=SOMMEPROD(($A$1:$A$20="Pierre")*($B$1:$B$20))
fizik-calc1.xlsx
(9.16 Kio) Téléchargé 2 fois
Prenons soins de nous et de notre vaisseau spatial, nous n’en n’avons qu’un ...notre planète terre
isabelle
E
Ergotamine
Membre fidèle
Membre fidèle
Messages : 400
Appréciations reçues : 26
Inscrit le : 26 juin 2016
Version d'Excel : 365

Message par Ergotamine » 5 janvier 2019, 23:04

Bonjour,

Une autre possibilité
=SOMME.SI($A$1:$A$6;"Pierre";$B$1:$B$6)
Bonne soirée.
Avatar du membre
i20100
Passionné d'Excel
Passionné d'Excel
Messages : 6'030
Appréciations reçues : 351
Inscrit le : 16 mars 2017
Version d'Excel : 2010

Message par i20100 » 5 janvier 2019, 23:48

re,

et une autre avec SOMME.SI.ENS
=SOMME.SI.ENS(B1:B6;A1:A6;"Pierre")
Prenons soins de nous et de notre vaisseau spatial, nous n’en n’avons qu’un ...notre planète terre
isabelle
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 6 janvier 2019, 11:03

Bonjour le forum,

Une matricielle à valider avec les touches CTRL MAJ ENTREE :
=SOMME((A1:A100="Pierre")*(B1:B100))
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message