(CSV) Export utf-8 , japonais, russe, arabe ... ? Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
Avatar du membre
djmisterjon
Membre habitué
Membre habitué
Messages : 67
Inscrit le : 20 août 2013
Version d'Excel : 2013 fr

Message par djmisterjon » 2 janvier 2019, 01:22

Bonjours, quelqun aurait quelque explication sur le théorique, car je n'arrive par a exporte mes traduction en CSV en prenant en charge les charactere japonais russe et autre langues spécial.

Comment faire.
Voici ce que j’essaie , logiquement cela devrai fonctionner ?
B4W8k9tN_o.jpg
ensuite lorsque je ouvre le csv dans un editeur.
J'ai encore ces drole de charactere !! ?
NvLE5PW2_o.png
Quelque aurai des explications sur le processus, je vous avoue ne pas être expert en traduction de langue pour application.
Je me suis assurer que l’éditeur qui ouvre le fichier text était bien aussi en utf-8
HWgp3NmQ_o.png
Je pense que ces du coter de Excel que il ya un problème !! !
Avatar du membre
djmisterjon
Membre habitué
Membre habitué
Messages : 67
Inscrit le : 20 août 2013
Version d'Excel : 2013 fr

Message par djmisterjon » 3 janvier 2019, 22:29

up merci.
je soupçonne Excel, car si je copy et colle des characters japonais direct dans vsCode ou ma console , cela fonctionne! , ces donc dans l’exportation de Excel qui a un soucie, mais je ne trouve pas quoi. Il dois me manque un setup quelque part !?
Avatar du membre
waard
Contributeur
Contributeur
Messages : 434
Appréciations reçues : 15
Inscrit le : 9 février 2015
Version d'Excel : 2013, 2016, FR
Téléchargements : Mes applications

Message par waard » 4 janvier 2019, 11:14

Hello,

J'ai ddl vscode, tenté sur visual, mes éditeurs notepad, notepad++ et tous ont bien montrés le texte en différentes langues du csv en mode utf, sans configuration préalable particulière.
Je ne pense pas que ce soit lié à Excel ou la configuration du fichier, néanmoins je te transfert mon fichier dans dernière config pour voir si chez toi cela marche.
Capture-1.jpg
Capture-1.jpg (31.16 Kio) Vu 837 fois
Étant donné que je code un truc en multilingue, il est possible que j'ai modifié la config des prises en charge des polices Windows, mais j'ai du le faire il y'a plus d'1/2 ans.
Capture-2.jpg
Dans les paramètres Windows > personnalisation > police > J'ai peut être installé toutes les polices de langues prises en charge par Windows, si chez toi ce n'est pas installé par défaut, c'est peut être à cause de ça ?
Sinon voir sur internet, en cherchant en anglais dans google par exemple "character not exist" + le nom de ton logiciel d'edition.

:wink:
Classeur1.csv
(990 Octets) Téléchargé 18 fois
"One and yet a mass"
COHENNY Tristan - Projet MYRMIDON
Avatar du membre
djmisterjon
Membre habitué
Membre habitué
Messages : 67
Inscrit le : 20 août 2013
Version d'Excel : 2013 fr

Message par djmisterjon » 5 janvier 2019, 13:34

waard a écrit :
4 janvier 2019, 11:14
Hello,

J'ai ddl vscode, tenté sur visual, mes éditeurs notepad, notepad++ et tous ont bien montrés le texte en différentes langues du csv en mode utf, sans configuration préalable particulière.
Je ne pense pas que ce soit lié à Excel ou la configuration du fichier, néanmoins je te transfert mon fichier dans dernière config pour voir si chez toi cela marche.
Capture-1.jpg
Étant donné que je code un truc en multilingue, il est possible que j'ai modifié la config des prises en charge des polices Windows, mais j'ai du le faire il y'a plus d'1/2 ans.
Capture-2.jpg
Dans les paramètres Windows > personnalisation > police > J'ai peut être installé toutes les polices de langues prises en charge par Windows, si chez toi ce n'est pas installé par défaut, c'est peut être à cause de ça ?
Sinon voir sur internet, en cherchant en anglais dans google par exemple "character not exist" + le nom de ton logiciel d'edition.

:wink:
Ton fichier fonctionne également chez moi!, ces donc pas un problem des police window, je comprend pas pourquoi quand j'export en CSV de mon coter ca ne fonctionne pas du tout !!.
Voici mon fichier test.
statesCalculator.xlsx
(66.25 Kio) Téléchargé 17 fois
selectionne la page `monstersInfo` ensuite
=>Fichier
=>Exporter
=>Modifier le type fichier
=>CSV

Une foi exporter! , peut importe avec quel editeur, le nouveau fichier .CSV est convertie avec des character du genre ?????????????????????????????????? pour les character chinois russe ou autre.

Pourtant il s'affiche bien dans excel.
Je ny comprend rien ! .

Merci pour toute aide ou indice
Avatar du membre
waard
Contributeur
Contributeur
Messages : 434
Appréciations reçues : 15
Inscrit le : 9 février 2015
Version d'Excel : 2013, 2016, FR
Téléchargements : Mes applications

Message par waard » 5 janvier 2019, 21:57

re :lole:

J'ai testé ton fichier et ça marche dans vscode sans soucis, j'ai tenté de modifier des paramètres pour retrouver l'erreur, mais je n'ai pas l'erreur.

En théorie pour avoir checké la faq de vscode, ça pourrait venir de la police utilisée, donc à voir si ta police dans excel que tu utilise est bien calibri comme ça apparait chez moi, car si c'est une police personnalisée, qui n'est pas connue par l'éditeur de vscode, peut être que la police utilisée par défaut, qu'utilise vscode pour la conversion, ne reconnait pas les caractères étrangers, car ils ne sont pas présent dans la police par défaut utilisée. Donc à voir peut être à changer la police excel, par calibri et vois si dans vscode tu utilise genre consolas (voir scan tout en bas).


- Peut être tenté de réinstaller les polices dans les paramètres windows que j'ai indiqué plus haut.
- Voir si la version Canadienne de windows, à les polices arabes, russes, chinois dans ses paramètres polices (normalement elles y sont, mais pas trop d'idées à part ça comme éventuelle source d'anomalie)


- Je te transmet ci-dessous les images, des options de mon dernier export utf, à tenter si l'erreur ne vient pas d'une option que tu aurais de différent ?
Capture-1.jpg
Capture-1.jpg (44.2 Kio) Vu 800 fois
Capture-2.jpg
Capture-2.jpg (79.27 Kio) Vu 800 fois
Capture-3.jpg
Capture-3.jpg (63.02 Kio) Vu 800 fois
Capture-4.jpg
Capture-4.jpg (59.62 Kio) Vu 800 fois
Capture-5.jpg
Capture-5.jpg (64.5 Kio) Vu 800 fois

- Et aussi les images des options de vscode et de mon extension langue installée (à voir dans le 1er scan, en bas dans la barre violette si les options sont identiques, j'ai vu quant modifiant ces options, ça pouvait changer l'affichage du texte, mais je n'ai pas eu ton erreur)
Capture-6.jpg
Capture-7.jpg
Capture-7.jpg (17.5 Kio) Vu 800 fois
Capture-8.jpg
Capture-9.jpg

Si tj en erreur, je pense qu'il faudra voir l'internet anglosaxon s'ils ont eu l'anomalie ou un forum qui traite vscode et assimilés.

:wink:
"One and yet a mass"
COHENNY Tristan - Projet MYRMIDON
Avatar du membre
djmisterjon
Membre habitué
Membre habitué
Messages : 67
Inscrit le : 20 août 2013
Version d'Excel : 2013 fr

Message par djmisterjon » 5 janvier 2019, 22:19

waard a écrit :
5 janvier 2019, 21:57
re :lole:

J'ai testé ton fichier et ça marche dans vscode sans soucis, j'ai tenté de modifier des paramètres pour retrouver l'erreur, mais je n'ai pas l'erreur.

En théorie pour avoir checké la faq de vscode, ça pourrait venir de la police utilisée, donc à voir si ta police dans excel que tu utilise est bien calibri comme ça apparait chez moi, car si c'est une police personnalisée, qui n'est pas connue par l'éditeur de vscode, peut être que la police utilisée par défaut, qu'utilise vscode pour la conversion, ne reconnait pas les caractères étrangers, car ils ne sont pas présent dans la police par défaut utilisée. Donc à voir peut être à changer la police excel, par calibri et vois si dans vscode tu utilise genre consolas (voir scan tout en bas).


- Peut être tenté de réinstaller les polices dans les paramètres windows que j'ai indiqué plus haut.
- Voir si la version Canadienne de windows, à les polices arabes, russes, chinois dans ses paramètres polices (normalement elles y sont, mais pas trop d'idées à part ça comme éventuelle source d'anomalie)


- Je te transmet ci-dessous les images, des options de mon dernier export utf, à tenter si l'erreur ne vient pas d'une option que tu aurais de différent ?
Capture-1.jpg
Capture-2.jpg
Capture-3.jpg
Capture-4.jpg
Capture-5.jpg


- Et aussi les images des options de vscode et de mon extension langue installée (à voir dans le 1er scan, en bas dans la barre violette si les options sont identiques, j'ai vu quant modifiant ces options, ça pouvait changer l'affichage du texte, mais je n'ai pas eu ton erreur)
Capture-6.jpg
Capture-7.jpg
Capture-8.jpg
Capture-9.jpg


Si tj en erreur, je pense qu'il faudra voir l'internet anglosaxon s'ils ont eu l'anomalie ou un forum qui traite vscode et assimilés.

:wink:
Merci infiniment pour toute ces informations tu est vraiment super.
Déjà si sa marche de ton coter, cela me permet d'avancer et ces une information importante, je vai experimenter et je te tien au courant des results.
Un grand merci mon ami
Avatar du membre
78chris
Passionné d'Excel
Passionné d'Excel
Messages : 5'608
Appréciations reçues : 421
Inscrit le : 9 juillet 2017
Version d'Excel : 2010 à 2019 + 365

Message par 78chris » 5 janvier 2019, 22:27

Bonjour

Si on utilise utf8 il faut utiliser une police adéquate pour voir les langues exotiques, Arial unicode par exemple.

Edit : à noter que les options Web n'ont rien à voir avec csv. Il faut soit sauvegarder en Txt unicode mais il y a une tabulation en séparateur soit utiliser VBA
Chris
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
Confucius
Avatar du membre
djmisterjon
Membre habitué
Membre habitué
Messages : 67
Inscrit le : 20 août 2013
Version d'Excel : 2013 fr

Message par djmisterjon » 5 janvier 2019, 23:37

waard a écrit :
5 janvier 2019, 21:57
re :lole:


:wink:
Bon voila merci a toi pour toute l'aide , j'ai trouver le coupable et ces bien ce foutu EXCEL !
Excel ne peut pas export en CSV ou text avec les delimiter point virgule; en UTF-8 ,et cela malgrer que on le force.

Il faut exporter manuellement au format .txt unicode.
dzkXlpzI_o.png
dzkXlpzI_o.png (9.35 Kio) Vu 178 fois
Et ensuite ouvrir dans votre éditeur pour moi ces [vscode]
Nltijbpc_o.png
Sélectionner manuellement tous les character ctrl+f tabulateur
Et faire un batch replace par un ;

voila
5Ghj07QF_o.png
Il aurait été de bonne alloua que les dev de Microsoft Excel émette un avertissement que les CSV point virgule; ne sont pas autoriser avec un encodage unicode et cela malgrer que on le force!!!
Voila , j’espère que cela aidera également d'autre dev d'application multi langue.
Il faut exporter en text, et replacer manuellement les tabs par les point virgule !!!
Ces un peut absurde et est plutôt anti-productif !!!
Je suis prenneur si quelqun a une autre technique plus productive au niveau workflow :)
Peut être fair un petit programme .bat qui fera ca automatiquement vous en penser quoi ?
@+
Modifié en dernier par djmisterjon le 5 janvier 2019, 23:47, modifié 1 fois.
Avatar du membre
djmisterjon
Membre habitué
Membre habitué
Messages : 67
Inscrit le : 20 août 2013
Version d'Excel : 2013 fr

Message par djmisterjon » 5 janvier 2019, 23:39

78chris a écrit :
5 janvier 2019, 22:27
Bonjour

Si on utilise utf8 il faut utiliser une police adéquate pour voir les langues exotiques, Arial unicode par exemple.

Edit : à noter que les options Web n'ont rien à voir avec csv. Il faut soit sauvegarder en Txt unicode mais il y a une tabulation en séparateur soit utiliser VBA
Oui je vient juste de remarquer , jecrivait au meme moment ou tu a rédiger le message haha!!! merci infiniment
Modifié en dernier par djmisterjon le 5 janvier 2019, 23:43, modifié 1 fois.
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message