Somme valeur cellule en dessous du resultat d'une recherche

Y compris Power BI, Power Query et toute autre question en lien avec Excel
b
baylesma
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 13 novembre 2018
Version d'Excel : 2016 FR

Message par baylesma » 13 novembre 2018, 15:42

Bonjour à tous,

Ça fait un petit moment que parcours les forums, et je ne trouve pas de solution à mon problème, surement par manque de connaissances ... voila pourquoi je fais appel à votre aide

Je vous explique ce que je cherche à faire:
Dans la MEME COLONE, j'ai successivement, du texte, une valeur, du vide, et on recommence ..... texte, valeur, vide ...
Je cherche à faire la somme des valeurs correspondants à label critère. Je sais pas si je me fais bien comprendre du coup on va faire un petit exemple, ca sera plus explicite !

pour l'exemple, on va dire que l'on est sur la colone A et qu'on démarre à la ligne 1

exemple:

toto
10

tata
20

titi
10

toto
20

en faisant une sorte de somme.si avec le critère "toto", je souhaiterais avoir le résultat 30 (10+20)
Pourriez vous m'aider à élaborer la formule si c'est possible ??

Merci par avance pour votre aide
U
U. Milité
Membre impliqué
Membre impliqué
Messages : 1'785
Appréciations reçues : 114
Inscrit le : 30 novembre 2016
Version d'Excel : Office 365

Message par U. Milité » 13 novembre 2018, 15:58

Bonjour et :bv3:

Pourquoi "une sorte" de SOMME.SI :) une "vraie" SOMME.SI fonctionnerait peut-être bien (mais avec un fichier en guise d'exemple, on aurait pu vérifier) ... teste donc quelque chose comme:
=SOMME.SI(A2:A11;"toto";A3:A12)
... avec un décalage d'une ligne entre les deux plages
b
baylesma
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 13 novembre 2018
Version d'Excel : 2016 FR

Message par baylesma » 13 novembre 2018, 16:12

bonjour, et merci pour cette réponse rapide :)

C’était aussi simple que ca !!! (je suis degouté !!!) il suffisait simplement de décaler la plage critère et la plage valeur (subtilité que je n'avais pas du tout compris... )

un grand merci pour ton aide

Je joint un fichier avec la solution que tu m'as proposée, si ca peut aider quelqu'un ...

MERCI BEAUCOUP
Classeur2.xls
(26 Kio) Téléchargé 2 fois
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message