Formule avec plusieurs SI

Y compris Power BI, Power Query et toute autre question en lien avec Excel
A
AR_Mdp
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 6 février 2018
Version d'Excel : 2016

Message par AR_Mdp » 26 octobre 2018, 15:50

Bonjour à tous,

Me voila bloqué dans la création d'un document à cause d'une formule.

Il faut que depuis une liste de choix (4 choix dispo), les 2 cases à côté se remplissent automatiquement.

Je vous joint un extrait de mon document avec les explications nécessaires.

Merci par avance pour votre aide !

En espérant avoir été clair sur ma demande.

Cdlt.
Classeur test pour forum excel.xlsx
(11.71 Kio) Téléchargé 8 fois
Avatar du membre
Pedro22
Passionné d'Excel
Passionné d'Excel
Messages : 3'700
Appréciations reçues : 373
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 26 octobre 2018, 15:57

Bonjour,

Une proposition de formule (à étendre vers le bas) :
-En E7 : =SIERREUR(INDEX($C$19:$E$22;EQUIV($D7;$D$19:$D$22;0);3);"")
-En F7 : =SIERREUR(INDEX($C$19:$E$22;EQUIV($D7;$D$19:$D$22;0);1);"")
Merci de prendre 30 sec pour lire la charte du forum.
Quelques conseils : ici
A
AR_Mdp
Nouveau venu
Nouveau venu
Messages : 5
Inscrit le : 6 février 2018
Version d'Excel : 2016

Message par AR_Mdp » 26 octobre 2018, 16:02

Merci Pedro22,

Cela fonctionne très bien sur le document test ; J'essaierais de l'étendre à tous mon document lundi.

Je pense avoir besoin du même genre de formule à d'autres endroit... Si je n'arrive pas à l'adaptée je reviendrais vers vous ! :D

Merci beaucoup, bon W-E
Avatar du membre
Pedro22
Passionné d'Excel
Passionné d'Excel
Messages : 3'700
Appréciations reçues : 373
Inscrit le : 26 janvier 2017
Version d'Excel : 2010 FR
Version de Sheets : FR
Téléchargements : Mes applications

Message par Pedro22 » 26 octobre 2018, 16:15

Pour détailler un peu plus :
- SIERREUR permet de ne rien afficher ("") si la formule qu'elle contient renvoie une erreur
- INDEX permet de renvoyer la valeur d'une matrice située à l'intersection de la ligne et la colonne définie dans la formule
- EQUIV renvoie la position d'un élément dans une plage à une dimension (combinée à la fonction INDEX, elle offre des possibilités similaires à une fonction RECHERCHEV ou RECHERCHEH)

PS : :btres:
Merci de prendre 30 sec pour lire la charte du forum.
Quelques conseils : ici
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message