remplisage automatique du résultat d'une formule Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
A
Aleksandra
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 13 août 2018
Version d'Excel : 2016

Message par Aleksandra » 11 septembre 2018, 13:00

Bonjour !

Merci pour votre aide lors de mes problèmes précédents !

Aujourd'hui je dois faire un fichier Excel prérempli pour les collaborateurs (ci-joint).

Colonne A : prénom
colonne B : menu déroulant avec le niveau de collaborateurs
Colonne C : un autre menu déroulant avec le %
Colonne D : Résultat avec une formule Si(et)

Je voudrais voir le résultat final (donc colonne D) UNIQUEMENT quand mes collaborateurs rempliront les DEUX colonnes demandées (colonnes B et C au même temps). J'aimerais bien avoir la colonne D vide jusqu'au moment où je ne remplis pas les deux critères.

Pourriez-vous m'aider, s'il vous plaît ? Évitez de vous moquer de ma formule trèèès longue ;)
pb excel.xlsx
(9.1 Kio) Téléchargé 3 fois
Avatar du membre
M12
Passionné d'Excel
Passionné d'Excel
Messages : 3'226
Appréciations reçues : 128
Inscrit le : 3 juillet 2015
Version d'Excel : 2013

Message par M12 » 11 septembre 2018, 13:13

Bonjour,

A mettre en D2 et tirer vers le bas
=SI(ET(B2="";C2="");"";SI(ET(B2="Responsable d'Agence Confirmé";C2="Validé moins de 80 % de quizz");"Responsable d'Agence";SI(ET(B2="Responsable Agence";C2="Validé moins de 80 % de quizz");"Responsable d'Agence";SI(ET(B2="Responsable d'Agence Senior";C2="Validé moins de 80 % de quizz");"Responsable d'Agence";B2))))
Merci de clôturer le fil en cliquant sur le bouton V vert du post à coté du bouton EDITER si problème résolu

Je ne répond pas au message privé
A
Aleksandra
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 13 août 2018
Version d'Excel : 2016

Message par Aleksandra » 11 septembre 2018, 13:24

M12,

Merci pour ta réponse, mais quand je copie-colle ta formule, j'ai toujours le résultat final qui s'affiche directement, quand je précise le niv de compétences 1 dans la colonne B...
Ci-joint le printscreen
pb excel.PNG
Avatar du membre
M12
Passionné d'Excel
Passionné d'Excel
Messages : 3'226
Appréciations reçues : 128
Inscrit le : 3 juillet 2015
Version d'Excel : 2013

Message par M12 » 11 septembre 2018, 13:33

Re,

Autant pour moi
c'est OU et non ET
=SI(OU(B2="";C2="");"";SI(ET(B2="Responsable d'Agence Confirmé";C2="Validé moins de 80 % de quizz");"Responsable d'Agence";SI(ET(B2="Responsable Agence";C2="Validé moins de 80 % de quizz");"Responsable d'Agence";SI(ET(B2="Responsable d'Agence Senior";C2="Validé moins de 80 % de quizz");"Responsable d'Agence";B2))))
1 membre du forum aime ce message.
Merci de clôturer le fil en cliquant sur le bouton V vert du post à coté du bouton EDITER si problème résolu

Je ne répond pas au message privé
A
Aleksandra
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 13 août 2018
Version d'Excel : 2016

Message par Aleksandra » 11 septembre 2018, 14:22

Merci !

Ca a très bien marché !

Bonne journée :)
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message