Générer un Top 10 mensuel sur base de données cumulées

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
primokorn
Membre fidèle
Membre fidèle
Messages : 196
Inscrit le : 1 novembre 2010
Version d'Excel : 365 ProPlus

Message par primokorn » 7 septembre 2018, 10:12

Bonjour,

Je souhaiterais vous soumettre un problème avec l'un de mes fichiers du boulot. Je l'ai simplifié mais la logique est là.

Fonctionnement du fichier et contexte :
• onglet "base" : j'importe des données cumulées avec un détail par client et article. Les colonnes AH et AI permettent de faire un regroupement par client (DO) et par Hiérarchie de clients (HIER)
• onglet "synth_YTD" : l'objectif est d'avoir une synthèse des montants en ayant un Top 10 des montants positifs et un autre Top 10 pour les négatifs.
• onglet "Detail_client" : je liste tous les prix à la hausse et à la baisse par client de l'onglet "base".
Je vais copier ces données dans l'onglet "Histo_Client". Ce dernier conserve tout l'historique.
Vu qu'on est sur des données cumulées, je dois faire la différence entre deux colonnes pour avoir un mensuel.

Mon problème est de sortir les résultats mensuels Top 10 des montants positifs et Top 10 des montants négatifs. En gros, la même chose que l'onglet "synth_YTD" mais en mensuel.
Je ne sais pas si c'est suffisamment clair pour appréhender le problème et si vous avez besoin de plus de données de base dans le fichier.

Merci d'avance à ceux qui se pencheront sur ce cas.
evolutions.xlsm
(150.79 Kio) Téléchargé 5 fois
Avatar du membre
primokorn
Membre fidèle
Membre fidèle
Messages : 196
Inscrit le : 1 novembre 2010
Version d'Excel : 365 ProPlus

Message par primokorn » 7 septembre 2018, 11:28

Pour info, j'ai essayé d'ajouter une colonne à droite de l'onglet "base" pour calculer la différence de "somme DO" entre deux mois cumulés.
Ça marche à 99%. Le 1% c'est les clients qui avaient un montant le mois dernier et plus ce mois-ci.
Avatar du membre
primokorn
Membre fidèle
Membre fidèle
Messages : 196
Inscrit le : 1 novembre 2010
Version d'Excel : 365 ProPlus

Message par primokorn » 7 septembre 2018, 11:47

En fait, je pense avoir trouvé une solution. Il n'y a pas vraiment de lignes qui disparaissent mais qui peuvent passer de 10 à 0 par exemple.

En AJ2 :
=SI(K2=K1;0;AH2-SOMME.SI.ENS('fichier_mois_precedent!$AH:$AH;'fichier_mois_precedent'!$K:$K;K2;'fichier_mois_precedent'!$A:$A;A2))
Si vous trouvez mieux, je reste preneur :)
j
jmd
Fanatique d'Excel
Fanatique d'Excel
Messages : 10'659
Appréciations reçues : 249
Inscrit le : 8 décembre 2007
Version d'Excel : 365 + PowerBI

Message par jmd » 7 septembre 2018, 13:36

bonjour

si ta formule fonctionne, conserve cette solution

note : ton fichier contient trop d'onglets et pas assez de données pertinentes, ni de résultat attendu.
si tu veux d'autres idées, fabrique un fichier exemple.

note 2 : les palmarès clients se font facilement avec des TCD triés (1 TCD pour les +, 1 pour les - )
Apprenez les fonctions d'Excel.
Exemple "Mettre sous forme de tableau", TCD, "Récupérer des données".
Apprendre les fonctionnalités "récentes".
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message