Formule matricielle ? Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
J
JU2018
Nouveau venu
Nouveau venu
Messages : 5
Appréciation reçue : 1
Inscrit le : 17 août 2018
Version d'Excel : 2010

Message par JU2018 » 17 août 2018, 09:32

Bonjour,

Je dois pouvoir faire la somme des valeurs situées en colonne E pour lesquelles une "x" apparaît en colonne U. C'est O.K. via "=SOMME.SI(U5:U162;"x";E5:E162)".

Seulement, il y a parfois des "DIV/O!" qui posent problème.

Je pense devoir utiliser une formule matricielle et quelque chose du style SIERREUR, ..., mais je n'y parviens pas.

Je vous joins mon fichier.

Merci de votre aide.

Ju
Somme.xlsx
(8.93 Kio) Téléchargé 5 fois
Avatar du membre
jpbt84
Membre dévoué
Membre dévoué
Messages : 548
Appréciations reçues : 6
Inscrit le : 18 juin 2016
Version d'Excel : 2016 FR

Message par jpbt84 » 17 août 2018, 09:40

Bonjour,

A tester !
{=SOMME((U1:U20="x");(SI(ESTERR(E1:E20);0;E1:E20)))}
:btres:
Formateur bureautique, certifié ECDL Expert
j
jmd
Fanatique d'Excel
Fanatique d'Excel
Messages : 10'659
Appréciations reçues : 249
Inscrit le : 8 décembre 2007
Version d'Excel : 365 + PowerBI

Message par jmd » 17 août 2018, 09:41

bonjour

dans la colonne mettre =SI(diviseur=0;0;tadivision)
de manière à traiter le problème des lignes vides (diviseur absent) au plus proche de la source : on teste le diviseur et non le résultat en erreur)

à noter que dans le langage DAX, un peu différent du langage de formules d'Excel, Microsoft a prévu et créé la fonction DIVIDE qui traite les divisions par zéro ou par null.
Apprenez les fonctions d'Excel.
Exemple "Mettre sous forme de tableau", TCD, "Récupérer des données".
Apprendre les fonctionnalités "récentes".
J
JU2018
Nouveau venu
Nouveau venu
Messages : 5
Appréciation reçue : 1
Inscrit le : 17 août 2018
Version d'Excel : 2010

Message par JU2018 » 17 août 2018, 09:49

Merci de votre aide.

Seulement, cela ne donne rien via Ctrl+Maj+Entrée :-(
Avatar du membre
jpbt84
Membre dévoué
Membre dévoué
Messages : 548
Appréciations reçues : 6
Inscrit le : 18 juin 2016
Version d'Excel : 2016 FR

Message par jpbt84 » 17 août 2018, 09:49

Tu pourrais mettre le fichier avec la formule que l'on puisse voir ?
Formateur bureautique, certifié ECDL Expert
j
jmd
Fanatique d'Excel
Fanatique d'Excel
Messages : 10'659
Appréciations reçues : 249
Inscrit le : 8 décembre 2007
Version d'Excel : 365 + PowerBI

Message par jmd » 17 août 2018, 09:50

re

normal, c'est un formule toute simple
laquelle as-tu essayée ?
Apprenez les fonctions d'Excel.
Exemple "Mettre sous forme de tableau", TCD, "Récupérer des données".
Apprendre les fonctionnalités "récentes".
J
JU2018
Nouveau venu
Nouveau venu
Messages : 5
Appréciation reçue : 1
Inscrit le : 17 août 2018
Version d'Excel : 2010

Message par JU2018 » 17 août 2018, 10:11

Voici
Somme.xlsx
(8.99 Kio) Téléchargé 3 fois
Avatar du membre
jpbt84
Membre dévoué
Membre dévoué
Messages : 548
Appréciations reçues : 6
Inscrit le : 18 juin 2016
Version d'Excel : 2016 FR

Message par jpbt84 » 17 août 2018, 10:17

Tu ne dois pas mettre les accolades, {}, elles se placent seules quand tu valides avec CTRL+MAJ+ENTER
Formateur bureautique, certifié ECDL Expert
J
JU2018
Nouveau venu
Nouveau venu
Messages : 5
Appréciation reçue : 1
Inscrit le : 17 août 2018
Version d'Excel : 2010

Message par JU2018 » 17 août 2018, 10:30

Euh, oui bien sûr :lol:

Seulement, il ne semble pas être tenu compte de la condition de la "x". La somme de toutes les cellules hors les "#DIV/O!) est effectuée, alors que moi, je n'ai besoin que de la somme des cellules pour lesquelles une "x" se trouve en colonne U.

Merci.
Avatar du membre
jpbt84
Membre dévoué
Membre dévoué
Messages : 548
Appréciations reçues : 6
Inscrit le : 18 juin 2016
Version d'Excel : 2016 FR

Message par jpbt84 » 17 août 2018, 10:34

Oui, je me suis planté dans la formule.

Il en s'agit pas de
{=SOMME((U1:U20="x");(SI(ESTERR(E1:E20);0;E1:E20)))}
Mais de
{=SOMME((U1:U20="x")*(SI(ESTERR(E1:E20);0;E1:E20)))}
Remplacer le ; par *
Formateur bureautique, certifié ECDL Expert
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message