Recherche d'informations par feuille

Y compris Power BI, Power Query et toute autre question en lien avec Excel
A
ArthurL18
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 2 août 2018
Version d'Excel : 2013 FR

Message par ArthurL18 » 2 août 2018, 14:55

Bonjour ! :D

J'ai une question très basique, excusez-moi pour cela, mais je n'y trouve pas de solution, alors je vais vous faire un petit topo :
Capture.JPG
Capture.JPG (27.12 Kio) Vu 124 fois
J'ai un classeur avec 6 feuilles, que l'on va numéroter de 1 à 6, et j'ai une première colonne qui contient ces numéros mais un peu dans le désordre.

Et, j'aimerais bien, quand une cellule de la première colonne contienne le numéro n, la cellule correspondante juste à côté aille puiser une certaine info dans la n-ième feuille (à l'aide d'un RECHERCHEV par exemple, ou peu importe, ce n'est pas le problème ici ^^)

Par exemple : en A2, j'ai un "2", alors j'aimerais que ma recherche en A3 aille puiser dans la 2ème feuille du classeur.

Et je n'ai pas trouvé comment le faire. :)

Je ne sais pas si j'ai été clair. J'aimerais automatiser un peu tout ça, car j'ai un fichier très volumineux, et tout faire à la main me prendrait une éternité ^^

Merci beaucoup ! :)
Et si je n'ai pas été clair, spécifiez le et je tenterai de ré-expliquer
m
massari59264
Membre fidèle
Membre fidèle
Messages : 474
Appréciations reçues : 8
Inscrit le : 29 avril 2017
Version d'Excel : 2016

Message par massari59264 » 2 août 2018, 14:57

Bonjour,

Joins un fichier à ta demande et un exemple de ce que tu souhaite obtenir,

Cordialement,
Avatar du membre
Valc
Membre fidèle
Membre fidèle
Messages : 228
Appréciations reçues : 17
Inscrit le : 19 juillet 2018
Version d'Excel : 2016

Message par Valc » 2 août 2018, 15:04

Bonjour,


=RECHERCHEV(D4;INDIRECT(A2&"!"&"$A$6:$B$7");2;FAUX)
Bonne continuation,



:btres:
A
ArthurL18
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 2 août 2018
Version d'Excel : 2013 FR

Message par ArthurL18 » 2 août 2018, 15:09

Magnifique Valc, merci !

Donc INDIRECT(CELLULE"!"&"MATRICE") réfère à la plage MATRICE, dans la feuille nommée comme CELLULE ? :)

(Je ne sais pas si c'est clair, mais vous me sauvez la vie haha, merci)
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message