Formule avec données de plusieurs feuilles et plusieurs cellules

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
Avatar du membre
Flow1995
Jeune membre
Jeune membre
Messages : 49
Inscrit le : 31 juillet 2018
Version d'Excel : 2016

Message par Flow1995 » 31 juillet 2018, 10:18

Bonjour,

J'ai un problème avec cette formule :
=NB.SI('01.08.2018:03.08.2018'!B54:C60;T(A3))

J'ai 3 feuilles nommées 01.08.2018, 02.08.2018 et 03.08.2018.
Et sur chaque feuilles j'ai 6 cellules de B54 à C60 (colonne B et C fusionnées).
J'ai une dernière feuille qui va me permettre de faire la somme de mes données si mon texte en A3 est identique à mes cellules de B54 à C60 de mes 3 feuilles.

Je ne sais pas si je suis assez clair dans mes explications.
J'ai une erreur de formule, mais je ne sais où. Formule situé sur la feuille 'Liste déroulante code' en AG3

Merci d'avance

Florian
ForumV1.xlsm
(178.57 Kio) Téléchargé 10 fois
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'171
Appréciations reçues : 448
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 31 juillet 2018, 10:22

Confusion de ma part... ::(
Modifié en dernier par MFerrand le 31 juillet 2018, 10:50, modifié 1 fois.
Avatar du membre
Flow1995
Jeune membre
Jeune membre
Messages : 49
Inscrit le : 31 juillet 2018
Version d'Excel : 2016

Message par Flow1995 » 31 juillet 2018, 10:33

Bonjour MFerrand,

Merci de ta réponse.

Enfaite je veux éviter les répétitions de tout les noms de mes feuilles, j'en ai une pour chaque jour du mois, donc 31, ca fait long à écrire.

=NB.SI('01.08.2018'!B54:C60;T(A3))+NB.SI('02.08.2018'!B54:C60;T(A3))+NB.SI('03.08.2018'!B54:C60;T(A3)) etc

Quand j'utilise cette formule, ca marche très bien.
Je voudrais juste l'appliquer sur une plage de feuille. De 01.08.2018 à 03.08.2018 pour l'instant et jusqu'à 31.08.2018 plus tard.

Est ce que c'est possible ?

Cordialement
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'171
Appréciations reçues : 448
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 31 juillet 2018, 10:58

Re,

Je ne vois pas ta formule dans ton classeur, pas de données, donc on calcule quoi ? et les plages n'ont pas l'air de correspondre... Il manque donc au moins un exemple.

Sinon, vois chez : http://boisgontierjacques.free.fr/pages ... prod3D.htm

Cordialement.
Avatar du membre
Flow1995
Jeune membre
Jeune membre
Messages : 49
Inscrit le : 31 juillet 2018
Version d'Excel : 2016

Message par Flow1995 » 31 juillet 2018, 11:17

J'ai mis un exemple dans le classeur.

Je veux que ca me calcul le nombre de fois que mon code est utilisé dans les ComboBox de toute les feuilles.
Ca marche bien pour la cellule AG3 quand je détaille une feuille après l'autre.
Mais dans la cellule AG4 quand je mets : '01.08.2018:03.08.2018' ca ne fonctionne pas.
Je ne comprends pas pourquoi il n'accepte pas cette plage de feuilles.
ForumV1.xlsm
(183.77 Kio) Téléchargé 9 fois
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message