comment sommer les valeurs d'une plage avec condition sur une autre plage?

Y compris Power BI, Power Query et toute autre question en lien avec Excel
p
pruvieros
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 26 janvier 2009
Version d'Excel : 2007 fr

Message par pruvieros » 26 juillet 2018, 20:29

Comment sommer les valeurs d'une colonne respectant une condition que l'on doit aller chercher dans une autre plage?

Ex: J'ai une première plage de deux colonnes: une colonne "Personnes" et une autre colonne "Salaire"

J'ai une autre plage de deux colonnes m'indiquant dans quelle ville habite chaque personne.

Il est nécessaire que ces deux plages soient séparées

Je cherche la formule qui va me donner la somme des salaires des parisiens...

J'ai fait un petit exemple dans le fichier joint, avec un exemple de tentative qui ne marche pas (j'essaye de combiner un recherchev avec une formule matricielle...)

Merci pour vos lumières!

Pruvieros
requête multi-tables sur excel.xlsx
(9.5 Kio) Téléchargé 6 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'378
Appréciations reçues : 238
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 26 juillet 2018, 21:04

Bonsoir le forum,

H2 :

=SOMMEPROD(($B$2:$B$9=G2)*($E$2:$E$9))

A tirer vers le bas.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'378
Appréciations reçues : 238
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 26 juillet 2018, 21:06

Re,

Ou :

=SOMME.SI.ENS(E:E;B:B;G2)
p
pruvieros
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 26 janvier 2009
Version d'Excel : 2007 fr

Message par pruvieros » 26 juillet 2018, 21:22

Merci beaucoup pour cette réponse.

Je réalise que j'ai trop simplifié le problème par rapport à ma situation.

Voici un deuxième fichier dans lequel:
- il n'y a pas autant de lignes dans une plage que dans l'autre
- Les plages ne sont pas côte à côte (dans ma situation réelle, elles sont sur deux feuilles séparées)

Le problème reste le même: comment sommer les salaires connus des parisiens (puis des marseillais, puis des lyonnais)

Encore une fois, merci par avance pour votre aide!

Pruvieros
requête multi-tables sur excel-v2.xlsx
(9.49 Kio) Téléchargé 2 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'378
Appréciations reçues : 238
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 26 juillet 2018, 21:37

Re,
SOMMEPROD 2.png
SOMMEPROD 2.png (12.42 Kio) Vu 103 fois
p
pruvieros
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 26 janvier 2009
Version d'Excel : 2007 fr

Message par pruvieros » 26 juillet 2018, 21:46

Merci encore, mais je n'ai pas le contrôle de l'ordre dans lequel les gens apparaissent dans la plage roses...
Ex:
requête multi-tables sur excel-v3.xlsx
(9.49 Kio) Téléchargé 2 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'378
Appréciations reçues : 238
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 26 juillet 2018, 21:53

Re,

F11 : =RECHERCHEV(D11;$A$2:$B$9;2;0)
SOMMEPROD 3.png
SOMMEPROD 3.png (16.65 Kio) Vu 93 fois
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'105
Appréciations reçues : 165
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 26 juillet 2018, 22:02

bonsoir
Ok mais si les noms ne sont plus au droit des villes ???????????????????????????????
un essai
pruvieros.xlsx
(10.41 Kio) Téléchargé 2 fois
cordialement
c'est en cherchant qu'on trouve
p
pruvieros
Nouveau venu
Nouveau venu
Messages : 9
Inscrit le : 26 janvier 2009
Version d'Excel : 2007 fr

Message par pruvieros » 26 juillet 2018, 22:05

Dupont est le seul parisien (dans le fichier v3)
Et effectivement, les noms ne sont plus au droit des villes.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'378
Appréciations reçues : 238
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 26 juillet 2018, 22:07

Où réside donc Jean ?
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message