Différences entre plusieurs colonnes Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
E
Elkbir
Jeune membre
Jeune membre
Messages : 21
Inscrit le : 16 octobre 2017
Version d'Excel : 2016

Message par Elkbir » 8 juin 2018, 13:29

Bonjour,

J'aurais voulu connaitre un moyen facile via une formule pour comparer les colonnes de mon fichier et voir s'il y a des différences entre celles-ci.
En gros voir si dans la colonne A il y a des différences avec la colonne C et E et si la colonne B a des différences avec la colonne D et F.

Merci d'avance
Comparatif Property Set Custom.xlsx
(14.17 Kio) Téléchargé 4 fois
E
Elkbir
Jeune membre
Jeune membre
Messages : 21
Inscrit le : 16 octobre 2017
Version d'Excel : 2016

Message par Elkbir » 8 juin 2018, 13:37

Je pensais à une recherche V mais je suppose que je dois le faire un nombre important de fois vu que ça marche pour 2 colonnes seulement
Avatar du membre
Ausecour
Passionné d'Excel
Passionné d'Excel
Messages : 3'119
Appréciations reçues : 346
Inscrit le : 31 mai 2018
Version d'Excel : 2010 FR, 2013 FR

Message par Ausecour » 8 juin 2018, 13:47

Bonjour,

Tu peux faire une formule de ce genre :
{=SI(SOMME(SI(A1:A4<>C1:C4;1;0))>0;"Différence";"Identique")}
Pour plusieurs colonnes, il suffit de rajouter comme ceci :
{=SI(SOMME(SI(A1:A4<>C1:C4;1;0);SI(A1:A4<>E1:E4;1;0))>0;"Différence";"Identique")}
:btres:
Plus un sujet a un titre précis, des explications claires, et un fichier Excel bien préparé, plus il a de chances d'avoir une réponse qui répond au besoin, mettez toutes les chances de votre côté :bien:
"100% des gagnants auront tenté leur chance" :trfl:
E
Elkbir
Jeune membre
Jeune membre
Messages : 21
Inscrit le : 16 octobre 2017
Version d'Excel : 2016

Message par Elkbir » 8 juin 2018, 14:15

Ausecour a écrit :
8 juin 2018, 13:47
Bonjour,

Tu peux faire une formule de ce genre :
{=SI(SOMME(SI(A1:A4<>C1:C4;1;0))>0;"Différence";"Identique")}
Pour plusieurs colonnes, il suffit de rajouter comme ceci :
{=SI(SOMME(SI(A1:A4<>C1:C4;1;0);SI(A1:A4<>E1:E4;1;0))>0;"Différence";"Identique")}
:btres:

Merci pour ta réponse mais mais je si j'ai bien compris je vois juste s'il y a des différences mais je ne vois pas où elles sont. J'ai pas précisé mais le but c'est que je vois quels sont les différences entre chaque colonne. Sachant que la valeur en A2 n'est pas nécessairement en C2 mais peut-être en C3, et que si c'est le cas je ne veux pas qu'il m'affiche la différence.

Je veux qu'excel me ressorte toutes les valeurs qui ne sont pas dans les 3 colonnes en gros.
Avatar du membre
Ausecour
Passionné d'Excel
Passionné d'Excel
Messages : 3'119
Appréciations reçues : 346
Inscrit le : 31 mai 2018
Version d'Excel : 2010 FR, 2013 FR

Message par Ausecour » 8 juin 2018, 14:36

Je te laisse avec une piste parce que j'ai du mal à voir comment faire... j'ai juste trouvé une mise en forme conditionelle pour faire ressortir les termes de la colonne A qui ne sont pas pareils que la colonne C

Après ça se fait sûrement en VBA mais... :bof:
Copie de Comparatif Property Set Custom (1).xlsx
(13.52 Kio) Téléchargé 2 fois
Plus un sujet a un titre précis, des explications claires, et un fichier Excel bien préparé, plus il a de chances d'avoir une réponse qui répond au besoin, mettez toutes les chances de votre côté :bien:
"100% des gagnants auront tenté leur chance" :trfl:
Avatar du membre
Xmenpl
Membre impliqué
Membre impliqué
Messages : 2'679
Appréciations reçues : 185
Inscrit le : 16 mai 2018
Version d'Excel : 2003 à 2013

Message par Xmenpl » 8 juin 2018, 14:58

Bonjour,

Si on peut utiliser les colonnes H et I
cela affichera uniquement :
- Dans colonne H quand ACE sont différents
- Dans colonne I quand BDF sont différents

Afficher la nature de la différence comme il y du texte, cela me paraît impossible ou au dessus de
mes facultés. :mrgreen:
Copie de Comparatif Property Set Custom.xlsx
(15.12 Kio) Téléchargé 2 fois
E
Elkbir
Jeune membre
Jeune membre
Messages : 21
Inscrit le : 16 octobre 2017
Version d'Excel : 2016

Message par Elkbir » 8 juin 2018, 15:02

Merci pour vos conseils, j'ai pas le temps de voir comment faire fonctionner ça actuellement donc je go manuellement finalement vu que ça presse..
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message