integrer une condition dans une condition

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
l
lyan
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 24 mai 2018
Version d'Excel : 2016

Message par lyan » 24 mai 2018, 18:26

Bonjour,

Tout d'abord je suis novice mais très travailleur.
je suis actuellement entrain de travailler sur un fichier perso, je bute sur la mise en place d'une formule pour la décote.

Je m'explique :
en B42 j'ai cette formule :=SI(1177-(B34*0,75)<=0;"0";1177-(B34*0,75))

Mon problème : Après le calcul du plafond du QF il faut parfois faire une rectification d’impôts. L’impôt calculé est de 3200 mais avec le plafond QF il devrait être en fait a 3500 d’impôts minimum après plafond. ce nouvel impôt se trouve en B40.

J'aimerai donc une conditions dans ma première formule, qui dit de prendre B40 et non B34 si (ou quand) B34<B40

Voici un fichier exemple un simple copier coller d'une partie du document.

Merci.
Bcp d'autres questions risque d'arriver..
Fichier exemple condition.xlsx
(10.9 Kio) Téléchargé 9 fois
o
ouisansdoute
Membre fidèle
Membre fidèle
Messages : 246
Inscrit le : 30 mai 2012
Version d'Excel : 2007-2010

Message par ouisansdoute » 24 mai 2018, 18:54

Bonjour,

Dans le fichier joint il n'y a rien en colonne B.

Une proposition cependant :
SI(B34<B40;1177-(B40*0,75)<=0;"0";1177-(B40*0,75);1177-(B34*0,75)<=0;"0";1177-(B34*0,75))
l
lyan
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 24 mai 2018
Version d'Excel : 2016

Message par lyan » 24 mai 2018, 20:00

Merci de votre réactivité je ferai au mieux pour être plus précis a l'avenir.

Quand je rentre la formule :=SI(B34<B40;1177-(B40*0,75)<=0;"0";1177-(B40*0,75);1177-(B34*0,75)<=0;"0";1177-(B34*0,75))
j'ai comme réponse : vous avez tapé un nombre trop important d'arguments pour cette fonction.


Cependant =SI(1177-(MAX(B34;B40)*0,75)<=0;"0";1177-(MAX(B34;B40)*0,75)) me donne le bon résultat.
Cette formule aussi : =SI(1177-(B34*0,75)<=0;"0";SI(B34>B40;1177-(B34*0,75);1177-(B40*0,75)))

Merci.
o
ouisansdoute
Membre fidèle
Membre fidèle
Messages : 246
Inscrit le : 30 mai 2012
Version d'Excel : 2007-2010

Message par ouisansdoute » 24 mai 2018, 20:37

J'étais allée un peu trop vite et ne l'avais pas testée.
Tant mieux si ca vous a mis sur la bonne voie.
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'898
Appréciations reçues : 694
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 25 mai 2018, 11:16

Bonjour lyan, ouisansdoute,

Je propose cette formule, dérivée de celle du message de lyan de 20:00
(et donc dérivée aussi d'une des formules de ouisansdoute) :

=MAX(0;1177-(MAX(B34;B40)*0,75))

⚠  je ne l'ai pas testée, mais je crois que ça devrait marcher ; donc à vérifier !

dhany
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message