RechercheV avec 2 valeurs à rechercher au lieu d'une Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
l
lovebo
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 3 mai 2018
Version d'Excel : 2016 EN

Message par lovebo » 3 mai 2018, 17:07

Bonjour à tous,

J'aimerais savoir s'il est possible d'effectuer une rechercheV avec 2 valeurs à rechercher au lieu d'une.

Rappelons que : = RECHERCHEV(valeur à rechercher, table, column num, true or false)

J'ai une table (avec une clé primaire à 2 attributs, disons les colonnes "nom" et "prenom") et une 3ème colonne date de naissance
J'aimerais rechercher dans cette table la valeur de cette date de naissance pour un nom et prénom donné.

J'ai bien entendu essayé avec une fonction RECHERCHEV en sélectionnant les 2 cellules, mais cela ne fonctionne pas.

Ci-joint un exemple très simple, avec la fonction que j'ai essayé en C8.
(=VLOOKUP(A8:B8;A2:C5;3;FALSE))
testExcelRechercheV.xlsx
Test excel rechercheV avec 2 valeurs
(8.64 Kio) Téléchargé 14 fois

Merci d'avance pour vos réponses,
Cordialement,
Lovebo
Avatar du membre
i20100
Passionné d'Excel
Passionné d'Excel
Messages : 5'537
Appréciations reçues : 321
Inscrit le : 16 mars 2017
Version d'Excel : 2010

Message par i20100 » 3 mai 2018, 17:10

Bonjour,

à tester,
formule matricielle à valider avec les touches ctrl+maj+enter
=INDEX(C2:C5;EQUIV(A8&B8;A2:A5&B2:B5;0))
1 membre du forum aime ce message.
Vive ces nouvelles saisons qui nous colorent.
isabelle
p
patrick1957
Passionné d'Excel
Passionné d'Excel
Messages : 3'123
Appréciations reçues : 31
Inscrit le : 24 août 2015
Version d'Excel : 2007-2010-2016 PC

Message par patrick1957 » 3 mai 2018, 17:12

Bonjour,

comme ceci ça doit aller :)

P.
testExcelRechercheV.xlsx
(8.69 Kio) Téléchargé 30 fois
1 membre du forum aime ce message.
Je fais du géocaching et vous ?
Indentez vos codes VBA, ---> http://www.oaltd.co.uk/Indenter/Default.htm
A lire pour les débutants: http://www.xlerateur.com/divers/2010/05 ... nnees-612/
l
lovebo
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 3 mai 2018
Version d'Excel : 2016 EN

Message par lovebo » 3 mai 2018, 17:19

Merci beaucoup à vous 2 pour votre temps et votre aide, c'est exactement ce que je cherchais. :)

Cordialement,
Lovebo
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message