[résolu] Question semblant simple

Y compris Power BI, Power Query et toute autre question en lien avec Excel
n
no-x
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 7 mars 2007

Message par no-x » 7 mars 2007, 09:19

Bonjour,
Je suis technicien informatique mais j'utilise très peu excel.
Un de mes amis m'a posé une colle qui semble pourtant tout bête:
il veut afficher dans une cellule 0 ou 1 selon si dans une autre cellule il a entré du texte.
Explication:
Si en A1 il a entré du texte, en Z1 il trouvera 1.
Si en A1 il n'a rien mis, en Z1 il trouvera 0

Voila ça a l'air tout bête mais je n'ai pas su le dépanner...
Sauriez vous le faire?
merci d'avance
Modifié en dernier par no-x le 7 mars 2007, 10:34, modifié 1 fois.
A
Amadéus
Modérateur
Modérateur
Messages : 17'748
Appréciations reçues : 73
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 7 mars 2007, 10:22

Bonjour

La formule suivante
=SI(ESTVIDE(A1);0;SI(ESTTEXTE(A1);1;""))

détermine les conditions suivantes:
Si A1 est vide, affiche 0
Si A1 contient du texte, affiche 1
Si A1 n'est pas vide et contient autre chose que du texte, n'affiche rien.

Pour être plus sélectif et répondre strictement à la question
=SI(ESTTEXTE(A1;1;0)
Si A1 est du texte, affiche 1, sinon affiche 0

Cordialement,

Amadéus
n
no-x
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 7 mars 2007

Message par no-x » 7 mars 2007, 10:33

Merci beaucoup pour cette réponse efficace et rapide.
Je bookmarque de suite ce forum :D
Merci encore
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message