Probleme de countif

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
N
Nieben
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 15 avril 2018
Version d'Excel : 2016FR

Message par Nieben » 15 avril 2018, 06:31

Bonjour,

j'essaye de faire une commande countif pour compter le nombre de date dans une colonne: =COUNTIFS(B2:B51;">01/01/2018") . Ce tableau doit me servir à compter les présences et les statistiques s'y rapportant. Malheureusement, j’obtiens [ #NOM?] et même avec une recherche conséquente sur le net, je ne suis pas arrivé à résoudre cela.

Je vous remercie d'avance.
V
VBABEGINNER
Membre dévoué
Membre dévoué
Messages : 728
Inscrit le : 5 novembre 2014
Version d'Excel : 2010

Message par VBABEGINNER » 15 avril 2018, 07:03

Bonjour,

Tu as mis une formule en anglais ... alors que ton message d'erreur nous laisse supposer que tu es en français ...

Esssaye donc avec NB.SI.ENS() au lieu de countifs...


Cordialement,

Vbabeginner
T
Theze
Passionné d'Excel
Passionné d'Excel
Messages : 4'019
Appréciations reçues : 306
Inscrit le : 26 janvier 2011
Version d'Excel : 2007/2019

Message par Theze » 15 avril 2018, 08:38

Bonjour,

Testes ceci : =NB.SI(B2:B51;">01/01/2018")
Il vaut mieux un qui sait que cent qui cherchent :wink:

Ce forum étant un lieu de partage, je n'accepte pas les messages privés !
N
Nieben
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 15 avril 2018
Version d'Excel : 2016FR

Message par Nieben » 15 avril 2018, 21:45

Merci de la réponse, je me mets à la tache.

Cordialement.
N
Nieben
Nouveau venu
Nouveau venu
Messages : 3
Inscrit le : 15 avril 2018
Version d'Excel : 2016FR

Message par Nieben » 16 avril 2018, 01:11

Re:

J'ai mis en place votre formule, cependant, j'ai deux colonnes où elle ne fonctionne pas: la première colonne donne un résultat à 0 et la deuxième colonne donne un résultat insuffisant. Pourtant , j'ai respecté la casse de votre formule: =NB.SI(AC4:AC53;">01/01/2016"). J'ai mis toutes les colonnes en "date à la française". Chose curieuse, la colonne de gauche de chaque colonne concernée par l'erreur est en nombre standard, aurait t-il une confusion de zone? Est il normal, que je doit valider par "entrée" la case de formule pour la mettre à jour?
T
Theze
Passionné d'Excel
Passionné d'Excel
Messages : 4'019
Appréciations reçues : 306
Inscrit le : 26 janvier 2011
Version d'Excel : 2007/2019

Message par Theze » 16 avril 2018, 06:38

Bonjour,
Est il normal, que je doit valider par "entrée" la case de formule pour la mettre à jour?
Dans ces colonnes, les dates sont au format texte.
Tu peux soit les valider par "Entrée" pour que Excel les transforme en dates valides, soit créer une colonne supplémentaire et tu utilises la fonction CNUM(). Il me semble avoir vu ici, il n'y a pas si longtemps, un post où un intervenant donnait une solution directement dans la formule, si je retrouve je te dirai.
Il vaut mieux un qui sait que cent qui cherchent :wink:

Ce forum étant un lieu de partage, je n'accepte pas les messages privés !
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • CountIF probleme
    par Spouns » 12 juin 2016, 11:58 » dans Excel - VBA
    5 Réponses
    258 Vues
    Dernier message par Spouns
    12 juin 2016, 21:38
  • Problème avec countif
    par Moons » 22 août 2014, 04:52 » dans Excel - VBA
    11 Réponses
    612 Vues
    Dernier message par frangy
    30 août 2014, 09:40
  • Problème avec la fonction COUNTIF
    par Captainmikou » 18 juin 2015, 09:07 » dans Excel - VBA
    2 Réponses
    300 Vues
    Dernier message par Captainmikou
    18 juin 2015, 10:13
  • Problème avec CountIf(plage cellules, = True)
    par iDev4s » 7 décembre 2016, 22:05 » dans Excel - VBA
    3 Réponses
    535 Vues
    Dernier message par MFerrand
    8 décembre 2016, 09:41
  • CountIf
    par Adyl2019 » 27 mars 2019, 15:40 » dans Excel - VBA
    5 Réponses
    67 Vues
    Dernier message par h2so4
    27 mars 2019, 17:40
  • Countif avancé
    par CDB » 17 février 2019, 12:03 » dans Excel - VBA
    13 Réponses
    353 Vues
    Dernier message par CDB
    17 février 2019, 21:14