Formule a plusieurs conditions

Y compris Power BI, Power Query et toute autre question en lien avec Excel
g
gouloom
Membre habitué
Membre habitué
Messages : 105
Inscrit le : 29 novembre 2016
Version d'Excel : 2007

Message par gouloom » 10 mars 2018, 18:00

Bonjour
J'ai des souci avec cette formule don je n'arrive pas a obtenir un résulta juste elle dois me donner le coût d'une journée de travail par collaborateurs
=SI(D12="collaborateur 1";SI(NB.SI(feries;B14);SI(A14="D";SI(E13="";"";D14-F13)*24*$AC$5+24*AB4+SI(E13>D13;MAX(0;MIN(E13;DebN)-MAX(D13;FinN));MAX(0;DebN-MAX(D13;FinN))+MAX(0;MIN(E13;DebN)-FinN))*24*$AC$5;)*2)+24*$AB$6;"")
Il y a 10 collaborateurs
D13 Prise de poste
E13 Fin de poste
F13 Total heures de jour
D14 Total heures de jour/nuit
F14 Total heures de nuit
Si A14 = jour férier alors +60%
Si A14 = Dimanche alors +100%
Si heur de nuit +10%
Si D12 = collaborateur 1 alors taux horaire de base AC5
Si D12 = collaborateur 2 alors taux horaire de base AF5
Si D12 = collaborateur 3 alors taux horaire de base AI5
Si D12 = collaborateur 4 alors taux horaire de base AL5
Si D12 = collaborateur 5 alors taux horaire de base AO5
Si D12 = collaborateur 6 alors taux horaire de base AR5
Si D12 = collaborateur 7 alors taux horaire de base AU5
Si D12 = collaborateur 8 alors taux horaire de base AW5
Si D12 = collaborateur 9 alors taux horaire de base AY5
Si D12 = collaborateur 10 alors taux horaire de base BA5
Cordialement
Mixcel.xlsb
(489.82 Kio) Téléchargé 11 fois
Modifié en dernier par gouloom le 11 mars 2018, 11:10, modifié 1 fois.
Avatar du membre
Florian53
Membre dévoué
Membre dévoué
Messages : 617
Appréciations reçues : 51
Inscrit le : 3 juin 2015
Version d'Excel : Office 365

Message par Florian53 » 10 mars 2018, 23:10

Bonsoir gouloom,

Voici un essai, redis moi si sa te convient, j'ai modifié également ta formule en "B13" afin de limiter les imbrications de bloc Si.
Mixcel2.xlsb
(490.15 Kio) Téléchargé 4 fois
Les grandes réussites sont le fruit de l'apprentissage durable. Apprenez à apprendre chaque jour.

:btres:
g
gouloom
Membre habitué
Membre habitué
Messages : 105
Inscrit le : 29 novembre 2016
Version d'Excel : 2007

Message par gouloom » 11 mars 2018, 10:33

Bonjour
Merci pour ton interet
ne tien pas compte de B13 Je l'utilise pas
mais ta formule omet les autre conditions renvois que le coût des heures de nuit
Cordialement
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message