Additionner par mois valeurs d'une même rubrique

Y compris Power BI, Power Query et toute autre question en lien avec Excel
L
Laurent22
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 3 mars 2018
Version d'Excel : étudiant 2010

Message par Laurent22 » 5 mars 2018, 14:32

Bonjour,
Je suis nouveau sur le forum, je tiens à vous féliciter pour la somme de connaissances que et vous remercier pour le partage des connaissances.
Avant hier j'ai posté une question mais je ne la retrouve pas dans la liste, peut être une fausse manoeuvre...
Mon problème:
Je souhaiterai additionner mensuellement les valeurs d'une même rubrique selon le tableau ci joint,. Je n'y arrive pas (je cherche sans sucés depuis au moins 2 heures) merci pour votre partage bien cordialement
Tableau brût
15/12/2017 blanc 10
16/12/2017 rose 8
17/12/2017 rouge 100
17/12/2017 blanc 20

02/01/2018 rose 5
12/01/2018 rouge 25
13/01/2018 blanc 155
20/01/2018 rose 200

Tableau résultats
déc-17 blanc 30
rose 8
rouge 100
janv-18 blanc 155
rose 205
rouge 25
Avatar du membre
DjiDji59430
Membre impliqué
Membre impliqué
Messages : 2'002
Appréciations reçues : 61
Inscrit le : 18 avril 2015
Version d'Excel : 2016 FR

Message par DjiDji59430 » 5 mars 2018, 14:37

Bonjour,

essaye :
=sommeprod((mois($a2=a8)=12)*(année($a2=a8)=2017)*($b2:$b$8="blanc")*($c$2:$c$8))

Cdlmnt
L
Laurent22
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 3 mars 2018
Version d'Excel : étudiant 2010

Message par Laurent22 » 5 mars 2018, 15:14

La formule que vous m'avez adressée donne un résultat erroné, je vous adresse le fichier pour faciliter la recherche. Merci pour votre réponse!
essais 1.xlsx
(9.65 Kio) Téléchargé 4 fois
Avatar du membre
AFEH
Membre dévoué
Membre dévoué
Messages : 737
Appréciations reçues : 17
Inscrit le : 21 juillet 2008
Version d'Excel : 2007 FR

Message par AFEH » 5 mars 2018, 18:10

Bonjour Laurent22 et le forum,
Essaie en C10
=SOMMEPROD((MOIS($A$2:$A$9)=12)*(ANNEE($A$2:$A$9)=2017)*($B$2:$B$9="blanc")*($C$2:$C$9))
Recopie la formule vers le bas en remplaçant "blanc" par "rosé" puis par "rouge" pour 2017 et ainsi de suite pour 2018
cdt
Henri
Avatar du membre
DjiDji59430
Membre impliqué
Membre impliqué
Messages : 2'002
Appréciations reçues : 61
Inscrit le : 18 avril 2015
Version d'Excel : 2016 FR

Message par DjiDji59430 » 5 mars 2018, 18:16

re
essais 2.xlsx
(10.46 Kio) Téléchargé 10 fois

Cdlmnt
Avatar du membre
eriiic
Passionné d'Excel
Passionné d'Excel
Messages : 9'147
Appréciations reçues : 351
Inscrit le : 7 février 2010
Version d'Excel : 2010fr

Message par eriiic » 5 mars 2018, 18:23

Bonjour,

avec un TCD.
Clic-droit dessus et Rafraichir si les données changent.
eric
essais 1.xlsx
(13.25 Kio) Téléchargé 4 fois
En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.
(les Shadoks)

En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message