Réaliser un graphique en enlevant certaines valeurs Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
b
binome18
Jeune membre
Jeune membre
Messages : 28
Inscrit le : 7 octobre 2015
Version d'Excel : 2010 FR

Message par binome18 » 22 février 2018, 18:19

Bonjour à tous,

Je viens vous solliciter pour une chose qui semble simple et qui pourtant me pose quelques problèmes.
Je souhaiterais réaliser un graphique sans que toutes les valeurs apparaissent.
Comme vous pouvez le voir dans le fichier ci-joint, la courbe "réalisé" est affichée sur le graphique jusqu'au mois de décembre. Or je souhaiterais qu'elle s'arrête en Février (parce que nous ne sommes qu'en Février), puis jusqu'en Mars, quand nous serons en Mars... En fait je veux que la courbe s'affiche quand les cellules en bleu du mois concerné sont remplies.

Les 110000€, c'est le budget que j'ai sur mon année complète. Il n'y a pas grand intérêt à faire une courbe avec, mais c'est juste pour visualiser le budget de l'année sur le graphique.
Le plan de consommation est tout simplement une fraction du budget total (qui s'additionne de mois en mois).
La ligne "réalisé" représente l'évolution du budget consommé depuis Janvier.

D'après mes connaissances sur Excel, pour que le graphique n'affiche pas de valeurs, il faut que les cellules concernées soient vides. J'ai donc cherché sur internet des astuces pour supprimer ou ajouter des valeurs en fonction du remplissage de certaines autres cellules, mais je n'ai rien trouvé qui puisse répondre à mon besoin.
J'ai vu des choses qui me sembles pas mal, c'est une sorte de macro à déclenchement automatique que l'on écrit dans le visual basic. J'arrive à réaliser des petites macros assez simples, mais écrire directement dans l'éditeur, c'est au dessus de mes connaissances actuelles.

J’espère que vous avez à peu près compris mon problème, n'hésitez à me poser des questions.

Merci d'avance pour l'aide que vous pourrez m'apporter.
Budget.xlsm
(16.52 Kio) Téléchargé 8 fois
Avatar du membre
78chris
Passionné d'Excel
Passionné d'Excel
Messages : 3'163
Appréciations reçues : 184
Inscrit le : 9 juillet 2017
Version d'Excel : 2010 à 2019

Message par 78chris » 22 février 2018, 19:02

Bonjour

Une solution (une MFC peut masquer les #N/A si cela te gêne)
Budget2.xlsm
(16.59 Kio) Téléchargé 12 fois
Chris
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
Confucius
b
binome18
Jeune membre
Jeune membre
Messages : 28
Inscrit le : 7 octobre 2015
Version d'Excel : 2010 FR

Message par binome18 » 23 février 2018, 17:51

Bonjour,

Merci pour cette réponse.
Est-ce que je pourrais avoir une petite explication sur la formule utilisée (=SI(DATEVAL(1&D1)<AUJOURDHUI();D9+C5;NA()))? surtout à propos de DATEVAL.
Cette version de fichier me plait bien, mais j'en voudrais plus.
Je souhaiterais qu'on ne tienne pas compte de la date du jour. Par exemple, si on rempli aujourd'hui une des cellules bleues du mois de Mars (alors qu'on est toujours en Février), je souhaite que le tableau fasse le calcul et que ça s'affiche sur le graphique.

Merci beaucoup pour votre aide.
Avatar du membre
78chris
Passionné d'Excel
Passionné d'Excel
Messages : 3'163
Appréciations reçues : 184
Inscrit le : 9 juillet 2017
Version d'Excel : 2010 à 2019

Message par 78chris » 23 février 2018, 20:41

Bonjour

Pour DATEVAL voir l'aide en ligne : cela renvoie une date à partir de texte pouvant être lu comme tel...

En C5 à tirer vers la droite
=SI(OU(NBVAL($B$6:C$6)=COLONNE()-1;NBVAL($B$8:C$8)=COLONNE()-1);C9+B5;NA())
Sous réserve qu'on ne saute pas de case bleue...
Chris
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
Confucius
b
binome18
Jeune membre
Jeune membre
Messages : 28
Inscrit le : 7 octobre 2015
Version d'Excel : 2010 FR

Message par binome18 » 24 février 2018, 19:11

Bonsoir,

Voilà qui me plait bien :)
Par contre, je n'arrive pas à faire la mise en forme conditionnelle pour "masquer" les #N/A.
J'ai appliqué une mise en forme conditionnelle en disant que quand la valeur de la cellule est égale à #N/A, alors on écrit en blanc. Mais cela ne semble pas fonctionner...
Vous sauriez m'expliquer pourquoi ?

Merci
Avatar du membre
78chris
Passionné d'Excel
Passionné d'Excel
Messages : 3'163
Appréciations reçues : 184
Inscrit le : 9 juillet 2017
Version d'Excel : 2010 à 2019

Message par 78chris » 24 février 2018, 22:44

Bonjour

Sur plage C5:M5

Formule de MFC au choix
=ESTERREUR(C$5)
ou
=ESTNA(C$5)
Chris
Quand un homme a faim, mieux vaut lui apprendre à pêcher que de lui donner un poisson.
Confucius
b
binome18
Jeune membre
Jeune membre
Messages : 28
Inscrit le : 7 octobre 2015
Version d'Excel : 2010 FR

Message par binome18 » 27 février 2018, 13:38

Parfait !
Tout fonctionne comme je le voulais.

Merci beaucoup :)
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message