Calculateur Coût Transport

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
b
benjamin S
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 21 février 2018
Version d'Excel : 2013 FR

Message par benjamin S » 21 février 2018, 14:37

Bonjour a tous ,

bon je suis un peu ( beaucoup ) comme tout ceux qui postent quelques choses sur ce forum une quiche en Excel ;)

je souhaiterais faire un calculateur très simple , qui me donnerait le coût d'une livraison suivant le département de livraison et du poids de la ou des palettes .

Récap :

un point de départ
Plusieurs points de livraison : 12 Zones + la Corse
un poids
un nombre de palette ( 3 maximum )

merci Beaucoup pour votre aide
Benjamin
transport.xlsx
(15.3 Kio) Téléchargé 86 fois
Avatar du membre
DjiDji59430
Membre impliqué
Membre impliqué
Messages : 2'288
Appréciations reçues : 86
Inscrit le : 18 avril 2015
Version d'Excel : 2019 FR

Message par DjiDji59430 » 21 février 2018, 16:26

Bonjour,

Un essai :

transport_v1.xlsx
(16.05 Kio) Téléchargé 84 fois

Cdlmnt
b
benjamin S
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 21 février 2018
Version d'Excel : 2013 FR

Message par benjamin S » 22 février 2018, 07:20

Bonjour DjiDji ,

merci beaucoup pour votre rapidité , juste un détail , a partir de 100kg le prix affiché est donné pour 100kg ; exemple pour 1 palette de 200Kg a destination du dpt 30 (zone 2 ) il faut multiplier 27.16€ par 2 soit 54.32€ ; pour 250 c'est 2.5 ... etc... c'est possible de l'automatiser ça ?

merci encore
Cdt
Benjamin
E
Eve_M
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 22 février 2018
Version d'Excel : 2016

Message par Eve_M » 22 février 2018, 08:17

Hello!

Essayes avec cette formule:
(Elle fait peur mais en réalité j'ai juste rajouté une condition)

=SI($E4>=100;$E4/100*SOMMEPROD(('Tarifs Zones '!$A$8:$A$20=RECHERCHEV("*"&TEXTE($B4;"00")&"*";'Tarifs Zones '!$A$25:$B$36;2;0))*(COLONNE('Tarifs Zones '!$B$4:$Q$4)-1=EQUIV('Calculateur '!$E4;'Tarifs Zones '!$B$4:$Q$4;1))*('Tarifs Zones '!$B$8:$Q$20));SOMMEPROD(('Tarifs Zones '!$A$8:$A$20=RECHERCHEV("*"&TEXTE($B4;"00")&"*";'Tarifs Zones '!$A$25:$B$36;2;0))*(COLONNE('Tarifs Zones '!$B$4:$Q$4)-1=EQUIV('Calculateur '!$E4;'Tarifs Zones '!$B$4:$Q$4;1))*('Tarifs Zones '!$B$8:$Q$20)))

Bien cdt,

Eve
b
benjamin S
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 21 février 2018
Version d'Excel : 2013 FR

Message par benjamin S » 22 février 2018, 09:48

Hello Eve ,

merci pour ta réponse !

lorsque je change la formule ça me met : #ref!

cdt
benjamin
E
Eve_M
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 22 février 2018
Version d'Excel : 2016

Message par Eve_M » 22 février 2018, 10:22

Avec le fichier car on ne travaille pas sur la même version d'excel :) :
Kopie von transport_v1.xlsx
(15.97 Kio) Téléchargé 92 fois
b
benjamin S
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 21 février 2018
Version d'Excel : 2013 FR

Message par benjamin S » 22 février 2018, 11:36

Super ça a l'air de marcher Nickel Ève !
merci a tous pour votre aide et votre rapidité !

cdt
Benjamin
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message