Compter les présences Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
S
Sebos
Jeune membre
Jeune membre
Messages : 45
Inscrit le : 12 novembre 2016
Version d'Excel : 2016

Message par Sebos » 12 février 2018, 09:14

Bonjour,

Je m'en remet à vous pour résoudre ma problématique ...

Dans le tableau en PJ, il y a 2 onglets.
Le 1er onglet est une liste de collaborateurs, ayant un responsable, une date d'entrée et une date de sortie.
Le 2nd onglet est un tableau que je voudrais remplir automatiquement, et qui puisse se mettre à jour en fonction d'ajout d'info dans le 1er onglet. L'objectif de ce 2nd onglet est de compter le nb de collaborateur par responsable en fonction du N° de semaine (sur 2018).

Dans l'exemple, je vous ai mis dans l'onglet 2 le début des chiffres (manuellement) que l'on devrait trouver.
Suivi charge entree sortie.xlsm
(14.21 Kio) Téléchargé 16 fois
J'espère que mes explications sont claires, n'hésitez pas si vous souhaitez un complément d'info.

Sebos.
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 13'161
Appréciations reçues : 734
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 12 février 2018, 09:57

Bonjour,
=SOMMEPROD(('entrees sorties'!$B$3:$B$9=$B4)*('entrees sorties'!$F$3:$F$9<=C$3)*('entrees sorties'!$G$3:$G$9>=C$3))
Modifié en dernier par Steelson le 12 février 2018, 12:09, modifié 1 fois.

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 13'161
Appréciations reçues : 734
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 12 février 2018, 10:10

en passant en tableau, ce sera plus simple
=SOMMEPROD((Tableau1[Responsables]=$B4)*(Tableau1[sem arrivée]<=C$3)*(Tableau1[sem départ]>=C$3))
Modifié en dernier par Steelson le 12 février 2018, 12:09, modifié 1 fois.

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
o
ouisansdoute
Membre fidèle
Membre fidèle
Messages : 247
Inscrit le : 30 mai 2012
Version d'Excel : 2007-2010

Message par ouisansdoute » 12 février 2018, 10:29

Bonjour voici une autre proposition

https://www.cjoint.com/c/HBmjpuyYS2R
g
gmb
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'519
Appréciations reçues : 317
Inscrit le : 4 avril 2013
Version d'Excel : 2016

Message par gmb » 12 février 2018, 10:42

Bonjour à tous

Une version macro.
Bye !
Suivi charge entree sortie v1.xlsm
(26.74 Kio) Téléchargé 6 fois
S
Sebos
Jeune membre
Jeune membre
Messages : 45
Inscrit le : 12 novembre 2016
Version d'Excel : 2016

Message par Sebos » 12 février 2018, 11:29

Bonjour à tous,

Merci pour vos réponses !
Steelson, merci beaucoup, mais je ne retrouve pas les chiffres calculés manuellement, peut-être y a t il un soucis dans les num de semaine, certaines dates d'arrivée ayant une année avant 2018, et les dates de départ pouvant être après 2018.

Pour Ouisansdoute, merci mais je n'arrive pas à ouvrir le fichier, il me dit fichier corrompu ou format inconnu, je suis preneur d'un nouvel essai !

gmb, merci pour le fichier avec macro, mais les chiffres en semaine 1 ne semblent pas correct. Est-ce la même problématique des années ? (les dates d'arrivée ou départ peut-etre avant ou après 2018)

Merci pour votre aide sur mon sujet !

Je reste dispo pour plus d'info si besoin.

Cordialement,

Sébastien
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 13'161
Appréciations reçues : 734
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 12 février 2018, 12:02

en effet, je suis allé au plus vite, je rajoute l'année !!

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
Avatar du membre
Steelson
Fanatique d'Excel
Fanatique d'Excel
Messages : 13'161
Appréciations reçues : 734
Inscrit le : 13 octobre 2014
Version d'Excel : 2013 FR
Téléchargements : Mes applications

Message par Steelson » 12 février 2018, 12:07

j'espère que c'est ok !
Suivi charge entree sortie.xlsm
(16.72 Kio) Téléchargé 5 fois

O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸ O.o°• ♪♪♫ °º¤ø,¸¸,ø¤º°`°º¤ø,¸
PI = 3.14159 26535 89793 23846 26433 83279 50288 41971 69399 37510 58209 74944 59230 78164 06286 20899 86280

( ͡• ͜ʖ ͡• )
Avatar du membre
Jean-Eric
Fanatique d'Excel
Fanatique d'Excel
Messages : 16'039
Appréciations reçues : 615
Inscrit le : 27 août 2012
Version d'Excel : 365 Insider

Message par Jean-Eric » 12 février 2018, 13:37

Bonjour,
Bonjour Steelson,
Pour le fun. :wink:
Bonne journée à tous.
Cdlt.
Suivi charge entree sortie.xlsm
(158.99 Kio) Téléchargé 7 fois
Jean-Eric

Je ne réponds pas aux M.P. non sollicités.
g
gmb
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'519
Appréciations reçues : 317
Inscrit le : 4 avril 2013
Version d'Excel : 2016

Message par gmb » 12 février 2018, 14:29

Sebos a écrit :
12 février 2018, 11:29
les chiffres en semaine 1 ne semblent pas correct. Est-ce la même problématique des années ?
Exact !
Cela tient en fait aux numéros de semaines.
Le premier janvier n'appartient pas forcément à la 1ère semaine de l'année mais parfois à la 53° de l'année d'avant.
De même pour le 31 décembre. Il n'est pas toujours à la 52° (ou 53°) semaine de l'année mais à la 1° semaine de l'année qui suit.

Nouvelle version à tester.
Bye !
charge entree sortie v2.xlsm
(27.2 Kio) Téléchargé 3 fois
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message