Gérer listes appels Tél et GSM Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
looky62
Jeune membre
Jeune membre
Messages : 22
Inscrit le : 9 février 2018
Version d'Excel : 2013

Message par looky62 » 12 février 2018, 08:46

Bonjour à tous,

Je vous expose mon problème, je souhaite créer une macro qui va me générer un filtre et faire un copier coller de mon résultat
j'ai 2 listes de numéro de Tél et GSM sur 2 colonnes
Je cherche a copier coller uniquement sur une 3em col, uniquement les numéros GSM
Malheureusement qd je lance ma macro, il me fait le fitre mais pas le copier coller des colonnes
Ci joint mon exemple pr etre plus clair

Merci d'avance pour votre aide et explication afin d'avancer
Test1.xlsx
(28.45 Kio) Téléchargé 16 fois
Avatar du membre
M12
Membre impliqué
Membre impliqué
Messages : 2'687
Appréciations reçues : 73
Inscrit le : 3 juillet 2015
Version d'Excel : 2013

Message par M12 » 12 février 2018, 09:11

Bonjour,

Sans macro et sans col E & F
A mettre en G2 par exemple
=SI(OU(GAUCHE(C2;2)="06";GAUCHE(C2;2)="07");C2;SI(OU(GAUCHE(D2;2)="06";GAUCHE(D2;2)="07");D2;"-"))
Merci de clôturer le fil en cliquant sur le bouton V vert du post à coté du bouton EDITER si problème résolu

Je ne répond pas au message privé
g
gmb
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'206
Appréciations reçues : 281
Inscrit le : 4 avril 2013
Version d'Excel : 2016

Message par gmb » 12 février 2018, 11:26

Bonjour à tous

Une version macro, sans utilisation des colonnes B à F
Bye !
Test1 v1.xlsm
(38.62 Kio) Téléchargé 19 fois
p
patrick1957
Passionné d'Excel
Passionné d'Excel
Messages : 3'159
Appréciations reçues : 31
Inscrit le : 24 août 2015
Version d'Excel : 2007-2010-2016 PC

Message par patrick1957 » 12 février 2018, 11:34

Bonjour,

allez ! GMB encore 2 msg , ça fera un beau compte :)

P.
Je fais du géocaching et vous ?
Indentez vos codes VBA, ---> http://www.oaltd.co.uk/Indenter/Default.htm
A lire pour les débutants: http://www.xlerateur.com/divers/2010/05 ... nnees-612/
g
gmb
Fanatique d'Excel
Fanatique d'Excel
Messages : 12'206
Appréciations reçues : 281
Inscrit le : 4 avril 2013
Version d'Excel : 2016

Message par gmb » 12 février 2018, 11:39

Bonjour Patrick

Je vais en verdir !
Bye !
Avatar du membre
looky62
Jeune membre
Jeune membre
Messages : 22
Inscrit le : 9 février 2018
Version d'Excel : 2013

Message par looky62 » 13 février 2018, 10:47

Merci les garçons !! C top
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message