Fonction NB.SI.ENS et intervalles Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
N
NiktonSlyp
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 7 février 2018
Version d'Excel : 2016

Message par NiktonSlyp » 7 février 2018, 17:56

Bonsoir à tous!

Cela fait plusieurs heures que je suis à la recherche d'informations à propos des critères de la fonction NB.SI.ENS, sans succès.
Désolé si un post correspond à cette question mais j'ai cherché également, sans succès.

Contexte du problème:
Je cherche à compter le nombre d’occurrence d'une valeur (ici, "D") dans un tableau en fonction de certaines valeurs de pH (chimie).
Donc, dans le cas où il n'y a pas de pH j'ai utilisé cette formule: =NB.SI.ENS('JCSG'!B3:B98;"D";JCSG!J3:J98;"")
'JCSG' étant la feuille contenant les données
B3 à B98 contient les différentes lettres que j'ai choisies pour mes conditions. J3 à J98 correspond à mes valeurs de pH.
En suivant cette formule, cela calcule le nombre de fois que la lettre "D" apparait en colonne !B lorsqu'aucune valeur de pH n'est mentionnée.

Problème :
Mon problème étant lorsque je choisis une valeur de pH en intervalle. Ce que je souhaite faire c'est obtenir le nombre de fois que la lettre "D" est représentée dans la colonne !B lorsque ma valeur de pH est comprise entre 4 et 5 par exemple.
J'ai bien essayé avec les "ET(!J>=4;!J<=5) mais la logique globale de ces formules m'échappe... Et je me suis tapé une erreur à chaque fois que j'ai tenté un truc hors de mes compétences! ::D

En vous remerciant d'avance, si vous avez une idée de la solution...

Julien
Avatar du membre
DjiDji59430
Membre impliqué
Membre impliqué
Messages : 1'917
Appréciations reçues : 56
Inscrit le : 18 avril 2015
Version d'Excel : 2016 FR

Message par DjiDji59430 » 7 février 2018, 18:02

Bonjour,

Fallait continuer avec ta formule !
dans ta formule il y a ENSemble !

=NB.SI.ENS('JCSG'!B3:B98;"D";JCSG!J3:J98;">="&4;JCSG!J3:J98;">="&5)

ce qui te donne le nombre de D pour un ph entre 4 et 5

Cdlmnt
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 8'433
Appréciations reçues : 280
Inscrit le : 16 juin 2013
Version d'Excel : 2013 UK Windows 10

Message par h2so4 » 7 février 2018, 18:05

bonsoir,

edit : bonsoir djidji,

essaie ceci
=NB.SI.ENS(JCSG!B3:B98;"D";JCSG!J3:J98;">=4";JCSG!J3:J98;"<=5")
N
NiktonSlyp
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 7 février 2018
Version d'Excel : 2016

Message par NiktonSlyp » 8 février 2018, 17:33

Bonsoir!

Merci beaucoup, cela fonctionne !
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message