Calcul de remise à palliers Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
M
Maxlrnt
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 10 janvier 2018
Version d'Excel : 2016

Message par Maxlrnt » 22 janvier 2018, 11:45

Bonjour,

Je cherche à calculer des remises en fonction de différent palliers selon un montant de dépenses.
La règle est la suivante : quand un pallier est atteint, il faut calculer la remise sur la différence entre les dépenses et le pallier avec le taux associé.
Dans l'exemple ci-joint, les résultats apparaissent dans la dernière colonne ; je souhaiterai une formule pour automatiser le calcul en colonne J, une fois les dépenses et les palliers renseignés.

D'avance merci
Exemple forum 2.xlsx
(11.06 Kio) Téléchargé 12 fois
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 8'982
Appréciations reçues : 359
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 22 janvier 2018, 12:26

bonjour,

une proposition, nous n'avons pas le même résultat pour la 2ème remise.
Exemple forum 2.xlsx
(11.62 Kio) Téléchargé 11 fois
M
Maxlrnt
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 10 janvier 2018
Version d'Excel : 2016

Message par Maxlrnt » 22 janvier 2018, 12:36

Bonjour,

Je me suis effectivement trompé pour la seconde remise.
En revanche doit-on nécessairement passer par un tableau annexe et une recherchev ? Je ne pourrai le mettre en place sur mon fichier de calculs de remise.

Merci
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 8'982
Appréciations reçues : 359
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 22 janvier 2018, 12:48

Bonjour,

formule adaptée à ta mise en page et à tes 4 paliers.
=SI(I2>G2;(I2-G2)*H2;SI(I2>E2;(I2-E2)*F2;SI(I2>C2;(I2-C2)*D2;0)))
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'526
Appréciations reçues : 227
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 22 janvier 2018, 13:02

bonjour
une contribution ;mais il y a un truc qui cloche
maxlrnt.xlsx
(9.4 Kio) Téléchargé 14 fois
cordialement
c'est en cherchant qu'on trouve
M
Maxlrnt
Jeune membre
Jeune membre
Messages : 14
Inscrit le : 10 janvier 2018
Version d'Excel : 2016

Message par Maxlrnt » 22 janvier 2018, 14:27

Bonjour,

Excellent, c'est tout à fait ça. Mille merci à vous!!

Maxime
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message