Format date Publipostage EXEL vers WORD Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
s
siga
Membre habitué
Membre habitué
Messages : 51
Inscrit le : 5 octobre 2016
Version d'Excel : 2010

Message par siga » 11 janvier 2018, 11:35

Salut
j'ai une base de donnée Excel à partir du quelle j'ai fait un publipostage. tous va bien juste format date n'est pas adequate, j'ai essayé plusieurs trucs mais ça n'a pas réussi.
voila ce que j'ai comme format: 12/14/2017 7:00:00 PM voila ce que je veux 12-04-2018 07:00 sans PM.
Merci pour l'aide
G
GVIALLES
Membre dévoué
Membre dévoué
Messages : 810
Appréciations reçues : 73
Inscrit le : 28 novembre 2017
Version d'Excel : 2016, 360
Téléchargements : Mes applications

Message par GVIALLES » 11 janvier 2018, 14:14

Bonjour Siga,

Une piste si tu peux modifier la source EXCEL: ajouter une colonne date en format texte dans laquelle tu mets la formule : =TEXTE(A1;"jj/MM/aaaa hh:mm") où A1 est la cellule contenant la date et dans WORD tu modifies le champ de fusion pour la date formatée.

Sinon, solution à ton problème dans WORD :

Dans le doc WORD de fusion, ajouter dernière le champ de fusion date :
\@ "dd/MM/yyyy hh:mm".

Pour pouvoir introduire ce code, tu dois, au préalable, aller dans les options WORD, Options Avancées et cocher la case : Afficher le code des champs....
optionsWord.jpg


Dans le doc de fusion tu obtiens alors à la place des champs de fusion quelquechose du genre :

{ MERGEFIELD nom du champ date }

dans lequel tu introduis le format voulu :


{ MERGEFIELD nom du champ date \@ "dd/MM/yyyy hh:mm" }
Cordialement,

Gérard
s
siga
Membre habitué
Membre habitué
Messages : 51
Inscrit le : 5 octobre 2016
Version d'Excel : 2010

Message par siga » 11 janvier 2018, 20:06

Merci bien pour l'explication :)
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message