Récupérer les 3 première lettre d'unProduit

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
j
jonthanGj3
Jeune membre
Jeune membre
Messages : 46
Inscrit le : 17 mai 2017
Version d'Excel : 2016

Message par jonthanGj3 » 8 janvier 2018, 15:11

Bonjour dans le cadre d'un teste pour mon entreprise.
Je cherche une formule qui me permettrai de prendre les 3 première lettre d'un mot:
La difficulté est qu'il sont parfois écrit sous la forme suivante:

2.2-Azinomachintruc :mrgreen:
ou
1,4-Dioxan

En gras ce que je souhaite récupérer

J'ai déja essayé des formules du genre

=Gauche("";1;1) sans grand succès

Merci d'avance pour votre aide

GRENIER Jonathan :wink:
g
gmb
Fanatique d'Excel
Fanatique d'Excel
Messages : 13'051
Appréciations reçues : 388
Inscrit le : 4 avril 2013
Version d'Excel : 2016

Message par gmb » 8 janvier 2018, 15:22

Bonjour

Essaie ça :
=STXT(A1;TROUVE("-";A1)+1;3)
Bye !
n
njhub
Membre impliqué
Membre impliqué
Messages : 1'505
Appréciations reçues : 86
Inscrit le : 5 juin 2017
Version de Calc : LO 6352 FR-YT

Message par njhub » 8 janvier 2018, 15:24

Bonjour jonthanGj3,

Essayez la formule ci-dessous
=SI(ESTERREUR(TROUVE("-";A1));GAUCHE(A1;3);GAUCHE(DROITE(A1;NBCAR(A1)-TROUVE("-";A1));3))
qui répond:

1235 123
2.2-Azinomachintruc Azi
1,4-Dioxan Dio
ABCDE ABC
FGHIJ-KLMP KLM
19876-ABC ABC
1 membre du forum aime ce message.
j
jonthanGj3
Jeune membre
Jeune membre
Messages : 46
Inscrit le : 17 mai 2017
Version d'Excel : 2016

Message par jonthanGj3 » 8 janvier 2018, 15:25

Merci de cette réponse aussi rapide

Malheureusement, j'ai une erreur comme quoi il faut que le mot soit en majuscule sachant qu'il y en a plus de 300 y 'aurait-il un moyen pour tous les passer en majuscule

Merci d'avance
g
gmb
Fanatique d'Excel
Fanatique d'Excel
Messages : 13'051
Appréciations reçues : 388
Inscrit le : 4 avril 2013
Version d'Excel : 2016

Message par gmb » 8 janvier 2018, 15:46

Voilà en majuscules pour ce qui concerne ma formule.
=MAJUSCULE(SIERREUR(STXT(A1;TROUVE("-";A1)+1;3);GAUCHE(A1;3)))
Bye !
1 membre du forum aime ce message.
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 8 janvier 2018, 17:30

Bonjour le forum,
=SIERREUR(MAJUSCULE(STXT(A1;CHERCHE("-";A1)+1;3));"")
1 membre du forum aime ce message.
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message