calcul de samedi et dimanche travailles Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
d
deviris
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 4 janvier 2018
Version d'Excel : 2010FR

Message par deviris » 4 janvier 2018, 13:56

bonjour,
étant débutant sur des forum , je croise les doigts pour que je sois le plus précis possible.
les dates sont remplie automatiquement ainsi que les jour qui correspond,sur un planning renseigner manuellement, j 'aimerai compter le nombre de dimanche/féries ainsi que de samedi que je travail (G ou J) en 2 cases separé
j'ai réussi a faire changer les cases de couleur si le jour est un dimanche ou un féries avec" =OU(NB.SI(Ferier2018;B2)=1;(JOURSEM(B2;2)=7))"
donc en utilisant le même principe de reconnaissance de date, j ai fait fait des tentative avec: "somme.si.ens ", "nb.si.ens" mais ca ne fonctionne pas. ::(

je vous remercie par avance du temps que vous allez passer sur mon poste.
document travail.xlsx
(19.41 Kio) Téléchargé 21 fois
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'789
Appréciations reçues : 262
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 4 janvier 2018, 15:02

bonjour
un essai rien que pour janvier avec deux façons
deviris.xlsx
(21.24 Kio) Téléchargé 18 fois
cordialement
c'est en cherchant qu'on trouve
d
deviris
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 4 janvier 2018
Version d'Excel : 2010FR

Message par deviris » 4 janvier 2018, 15:34

bonjour et, un grand merci pour votre réactivité.
il y a déjà un grand pas de fait au vu de mes essais pitoyables :lole: mais, dans l'exemple que vous avez donnez, il compte "c" comme un jour travaillé alors que c est un "congé".il faudrait juste compter si c est "G"ou "J".

=SOMMEPROD(((JOURSEM(AB3;2)>=6)+($H$33:$I$45=AB3))*(AB4<>"")):

si je comprend,

(JOURSEM(AB3;2)>=6) cherche ab3 est un dimanche on additionne les deux resultats(+) ($H$33:$I$45=AB3) cherche si ab3 correspond a la liste des férié

(AB4<>"") ça je ne suis pas sur de comprend :bof:; je dirai "non vide?
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'789
Appréciations reçues : 262
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 4 janvier 2018, 16:56

re
re essai
a saisir en B5 puis tirer a droite
=SOMMEPROD(((JOURSEM(B3;2)>=6)+($H$33:$I$45=B3))*((B4<>"")*(B4<>"c")))
cordialement
c'est en cherchant qu'on trouve
d
deviris
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 4 janvier 2018
Version d'Excel : 2010FR

Message par deviris » 4 janvier 2018, 17:26

merci pour ces informations,
de mon coté j ai continuer a travaillé sur le dossier :wink:

je rencontre une difficulté sur le férié qui tombe un dimanche, il me le compte 2 fois (cf avril) :cry:
tableau deviris-1.xlsx
(21.05 Kio) Téléchargé 11 fois
A
Amadéus
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'620
Appréciations reçues : 79
Inscrit le : 7 mai 2006
Version d'Excel : Office Excel 2003 FR et 2013FR

Message par Amadéus » 4 janvier 2018, 18:27

Bonjour, salut Tulipe
On compte le total des G ou J du mois (ou les deux) et on soustrait les G ou J des jours ouvrés.
Cordialement
document travail.xlsx
(19.73 Kio) Téléchargé 14 fois
Amadéus vous informe que, pour cause de saturation, il ne peut plus répondre aux messages privés non sollicités.
d
deviris
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 4 janvier 2018
Version d'Excel : 2010FR

Message par deviris » 4 janvier 2018, 18:45

bonjour Amadeus et merci de te pencher sur mon problème. :)
ce n'est pas le nombre de G ou j que je souhaite compter mais le nombre de samedi et dimanche, jour fériés travaillés.
ce qui me permettrait de remplir une case nb de samedi travaillé et une autre avec nb de dimanche ferié. travaillés.

ou la la, j'espère que mes explications sont claires :lole:
d
deviris
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 4 janvier 2018
Version d'Excel : 2010FR

Message par deviris » 4 janvier 2018, 19:54

tulipe_4 et Amadeus,
merci du temps que vous me consacrer.
voici ce qui semble fonctionner grâce a vos explications, qu'en pensez vous?
document travail2 tulipe amadéus .xlsx
(20.97 Kio) Téléchargé 24 fois
d
deviris
Nouveau venu
Nouveau venu
Messages : 6
Inscrit le : 4 janvier 2018
Version d'Excel : 2010FR

Message par deviris » 12 janvier 2018, 15:53

Un grand merci a tous pour votre aide cela fonctionne bien.

Je ne trouve pas le bouton pour marquer que le problème est résolu :oops:
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message