Un genre de sommeprod entre lignes et colonnes avec condition Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Avatar du membre
andreleca
Membre habitué
Membre habitué
Messages : 78
Inscrit le : 18 septembre 2009
Version d'Excel : 2016 FR

Message par andreleca » 31 décembre 2017, 22:00

Bonjour à vous,
Je joins un fichier avec lequel j'aimerais calculer une valeur (K3 de la feuille 1) provenant de données présenté en colonne ( le temps à feuille 1) X par (le taux horaire de la feuille2) pour les même activités. Je sais que si je transcrit mes données de la feuille 2 sur la feuille 1 je peut faire une simple sommeprod, mais il doit surement avoir une solution plus efficace.
Merci beaucoup ... d'avance et joyeuses fêtes!!
Test.xlsx
(9.45 Kio) Téléchargé 7 fois
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'194
Appréciations reçues : 446
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 1 janvier 2018, 02:26

Bonjour,
=SOMMEPROD(D3:I3;TRANSPOSE(Feuil2!C3:C8))
A valider matriciellement, malgré SOMMEPROD...

Cordialement.
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'523
Appréciations reçues : 225
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 1 janvier 2018, 12:26

bonjour
meilleurs voeux
=SOMMEPROD(SOMME.SI(Feuil2!B3:B8;Feuil1!D2:I2;Feuil2!C3:C8)*(D3:I3))
sans validation tridactyle :lol:
cordialement
c'est en cherchant qu'on trouve
M
MFerrand
Fanatique d'Excel
Fanatique d'Excel
Messages : 17'194
Appréciations reçues : 446
Inscrit le : 20 juillet 2015
Version d'Excel : 2010 FR

Message par MFerrand » 1 janvier 2018, 14:46

Oh ! :appl2: Mais déjà affuté pour 2018 !
Avatar du membre
andreleca
Membre habitué
Membre habitué
Messages : 78
Inscrit le : 18 septembre 2009
Version d'Excel : 2016 FR

Message par andreleca » 1 janvier 2018, 23:07

Super, merci beaucoup!
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message