Condition if Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
k
kamellias
Membre habitué
Membre habitué
Messages : 108
Appréciation reçue : 1
Inscrit le : 10 février 2017
Version d'Excel : 2010

Message par kamellias » 23 décembre 2017, 11:55

Bonjour,

je souhaiterai a partir de la ligne 2 jusqu'a la derniere vers la droite de toutes les colonnes renseignes creer une conditions if

exemple: si la cellule en A2 = ATR alors en A1 = TR98

voir le classeur c'est plus clair

merci
Classeur1.xlsx
(9.62 Kio) Téléchargé 18 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'293
Appréciations reçues : 228
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 23 décembre 2017, 13:03

Bonjour le forum,

Sans aucune conviction :

A1 :
=SIERREUR(CHOISIR(EQUIV(A2;{"ATR";"ABR";"AKE";"AMJ"};0);"TR98";"TR34";"TX87";"TR45");"")
A tirer vers la droite.
k
kamellias
Membre habitué
Membre habitué
Messages : 108
Appréciation reçue : 1
Inscrit le : 10 février 2017
Version d'Excel : 2010

Message par kamellias » 23 décembre 2017, 13:16

Bonjour,

tu pourrais le mettre en vba svp car c est pour rajouter a ma macro

merco
k
kamellias
Membre habitué
Membre habitué
Messages : 108
Appréciation reçue : 1
Inscrit le : 10 février 2017
Version d'Excel : 2010

Message par kamellias » 23 décembre 2017, 14:20

voila ce que j ai fait ca fonctionne mais que sur une colonne
je souhaiterai un de pouce pour faire une boucle sur toutes les colonnes
Sub ddd()
 Dim i As Integer
 
  For i = [A65000].End(xlUp).Row To 1 Step -1
     If Cells(i, 1) = "CD5279" Then 'ams1
     
     i = i - 1
 Cells(i, 1).Value = "XXX"
     End If
       Next i
End Sub
Avatar du membre
Patty5046
Membre impliqué
Membre impliqué
Messages : 1'335
Appréciations reçues : 135
Inscrit le : 2 février 2016
Version d'Excel : 2016

Message par Patty5046 » 24 décembre 2017, 16:27

Bonsoir

Voici ton code modifié pour aller jusqu'à la dernière colonne
Sub test()
 Dim i As Integer
 c = Range("A1:A255").End(xlToRight).Column
    For i = [A65000].End(xlUp).Row To 1 Step -1
        For col = 1 To c
            If Cells(i, col) = "CD5279" Then 
                Cells(i, col).Value = "XXX"
            End If
        Next col
    Next i
End Sub
Vois si cela te convient

Bonnes fêtes
k
kamellias
Membre habitué
Membre habitué
Messages : 108
Appréciation reçue : 1
Inscrit le : 10 février 2017
Version d'Excel : 2010

Message par kamellias » 24 décembre 2017, 17:38

Super je te remercie ::D

Bonnes fêtes également
Avatar du membre
Patty5046
Membre impliqué
Membre impliqué
Messages : 1'335
Appréciations reçues : 135
Inscrit le : 2 février 2016
Version d'Excel : 2016

Message par Patty5046 » 24 décembre 2017, 17:45

Bonsoir
N'oublie pas de mettre en résolu

A + ??
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message