Adaptation formule rechercheV Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
P
Patakess
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 20 décembre 2017
Version d'Excel : 2010 FR

Message par Patakess » 22 décembre 2017, 09:56

Bonjour, c'est encore moi :) Promis cette fois je mettrai un vrai exemple avec un fichier direct :)

Voilà, je travaille sur Excel avec adaptation sur google sheet. Je voudrais, dans le fichier joint, que on recherche dans la feuille 1 pour mettre le poste de cette Natacha à chaque heure de la journée. J'ai essayé RechercheV, mais je n'arrive pas à faire un 'saut' de colonne.

Petit problème aussi, la fonction équivalente sur google sheet ne recherche la clé que dans la première colonne de la plage donnée...

Voilà voilà, merci de votre aide de base
Test_planning_benevole_final.xlsx
(78.57 Kio) Téléchargé 4 fois
t
thebenoit59
Membre fidèle
Membre fidèle
Messages : 438
Appréciations reçues : 9
Inscrit le : 21 juin 2016
Version d'Excel : 2016

Message par thebenoit59 » 22 décembre 2017, 10:12

Bonjour Patakess.

Je ne connais pas Google Sheet, donc je ne sais pas si la formule fonctionne.
En [B2] :
=SIERREUR(INDEX('Planning Samedi'!$A:$A;EQUIV($A2;'Planning Samedi'!B:B;0));"")
A étirer.
P
Patakess
Jeune membre
Jeune membre
Messages : 11
Inscrit le : 20 décembre 2017
Version d'Excel : 2010 FR

Message par Patakess » 22 décembre 2017, 10:22

Bonjour.

Oh ben ça fonctionne parfaitement. Il va falloir que je me penche sur cette fonction Index, j'avoue ne pas la connaitre mais ça fait plusieurs fois que je la vois sortir pour régler différent soucis.

Merci beaucoup :)
t
thebenoit59
Membre fidèle
Membre fidèle
Messages : 438
Appréciations reçues : 9
Inscrit le : 21 juin 2016
Version d'Excel : 2016

Message par thebenoit59 » 22 décembre 2017, 10:24

Index renvoie la valeur en fonction d'un numéro de ligne et de colonne, ici je n'ai pas entré de numéro de colonne car il n'y en a qu'une seule.
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message
  • Adaptation de formule en VBA
    par criscris11 » 2 juillet 2014, 08:59 » dans Excel - VBA
    2 Réponses
    172 Vues
    Dernier message par criscris11
    2 juillet 2014, 11:47
  • Adaptation écriture formule => VBA
    par dm83 » 2 décembre 2018, 14:10 » dans Excel - VBA
    3 Réponses
    60 Vues
    Dernier message par thev
    2 décembre 2018, 16:34
  • Adaptation de formule en code vba
    par Tieuma66 » 24 mai 2019, 11:04 » dans Excel - VBA
    3 Réponses
    67 Vues
    Dernier message par Tieuma66
    27 mai 2019, 13:27
  • Adaptation
    par MJC55 » 16 mai 2016, 10:10 » dans Excel - VBA
    2 Réponses
    105 Vues
    Dernier message par MJC55
    16 mai 2016, 10:29
  • Adaptation macro
    par atlonia » 26 août 2017, 09:57 » dans Excel - VBA
    8 Réponses
    250 Vues
    Dernier message par archer
    28 août 2017, 12:25
  • Adaptation de code
    par FinaMtl » 10 janvier 2019, 03:00 » dans Excel - VBA
    5 Réponses
    106 Vues
    Dernier message par Jean-Eric
    11 janvier 2019, 10:03