Horaire Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
g
grenireg
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 8 décembre 2017
Version d'Excel : 2007 FR

Message par grenireg » 8 décembre 2017, 21:10

Bonjour a tous,

Je suis nouveau sur le site et me débrouille pas trop en excel.
Je vous explique un peu ce que je voudrais,( fichier joint)
TestHoraire.xlsx
(10.56 Kio) Téléchargé 5 fois
.

Supposons que la journée de dimanche je choisi Jean( a partir d'un menu déroulant) dans la case horaire de 7h à 15h case B2, je voudrais que le nombre d'heures travaillées (ici 8h) soit inscrit dans la cellule se rapportant a cette personne en B18 pour ce cas-ci.

Si je chosi Jacques le mardi en D4 (de 15h30 à 21h) il faudrait afficher 5h30 dans sa case correspondante en D19.

Et si la personne fait un double cette journée là, il faudrait afficher le total de la journée.
ex. Jacques le jeudi en F3 et F5.

Merci et bonne journée a tous.
Avatar du membre
vbMsgBoxHelpButton
Membre fidèle
Membre fidèle
Messages : 290
Appréciations reçues : 15
Inscrit le : 7 décembre 2017
Version d'Excel : 2007 FR

Message par vbMsgBoxHelpButton » 8 décembre 2017, 21:23

Bonsoir,
Voici une formule à copier coller sur l'ensemble du tableau du dessous :
=SOMMEPROD(($B17=C$2:C$14)*($A$2:$A$14)*($B17<>""))
Elle est à inscrire pour la première en cellule C17 ! Et oui pour une simplicité de calcul, j'ai ajouté une colonne à gauche, ce qui a tout décalé, sur cette colonne j'ai indiqué le nombre d'heure qui correspondait à la tranche de travail. Sinon pour le reste cela additionne par jour en fonction des personnes.
Voici le fichier modifié :
TestHoraire_vbMBHB.xlsx
(10.92 Kio) Téléchargé 14 fois
vbMBHB
vbMsgBoxHelpButton ou bien 16384 pour les intimes :lole:
Je pars pour un très long voyage, donc aujourd'hui le 08/02/2018, je vous dis "au revoir" (°v°)°
g
grenireg
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 8 décembre 2017
Version d'Excel : 2007 FR

Message par grenireg » 8 décembre 2017, 21:31

Merci infiniment,
J'apprécie la rapidité et la qualité de ton intervention.
Ta réponse fait mon bonheur,

Merci encore
Avatar du membre
vbMsgBoxHelpButton
Membre fidèle
Membre fidèle
Messages : 290
Appréciations reçues : 15
Inscrit le : 7 décembre 2017
Version d'Excel : 2007 FR

Message par vbMsgBoxHelpButton » 8 décembre 2017, 21:39

Merci
:btres:
vbMBHB
vbMsgBoxHelpButton ou bien 16384 pour les intimes :lole:
Je pars pour un très long voyage, donc aujourd'hui le 08/02/2018, je vous dis "au revoir" (°v°)°
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message