Valeur non vue si identique à celle du dessus Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
Répondre
g
gui_29
Nouveau venu
Nouveau venu
Messages : 8
Inscrit le : 11 avril 2014
Version d'Excel : 2010 FR

Message par gui_29 » 23 novembre 2017, 09:06

Salut à tous,

J'utilise un onglet pour remettre en forme les données d'un export copié dans un autre onglet.

Dans mon exemple, dans la colonne "Sous-ensembles" j'aimerais que le texte apparaisse avec la première ligne mais ne s'affiche pas sur les lignes suivantes si le texte est identique.

J'ai essayé une formule mais qui ne fonctionne qu'une case sur deux.

Avez-vous une idée de formule qui fonctionnerait?
Exemple.xlsx
(12.27 Kio) Téléchargé 10 fois
U
U. Milité
Membre impliqué
Membre impliqué
Messages : 2'048
Appréciations reçues : 144
Inscrit le : 30 novembre 2016
Version d'Excel : Office 365

Message par U. Milité » 23 novembre 2017, 09:32

Bonjour,

En A2 de la Feuil2, tu peux sans doute utiliser
=SI(NB.SI(Feuil1!A$2:A2;Feuil1!A2)=1;Feuil1!A2;"")
Attention de ne jamais trier les données de la Feuil1, ni y supprimer des lignes (faute de quoi toutes les formules en Feuil2 risquent de renvoyer des erreurs (ou des résultats erronés)
h
h2so4
Passionné d'Excel
Passionné d'Excel
Messages : 9'493
Appréciations reçues : 431
Inscrit le : 16 juin 2013
Version d'Excel : 365 UK Windows 10

Message par h2so4 » 23 novembre 2017, 09:33

bonjour

essaie ceci mettre en A2 et tirer vers le bas
=SI(NB.SI($A$1:$A1;Feuil1!A2)=0;Feuil1!A2;"")
Avatar du membre
lauange
Membre fidèle
Membre fidèle
Messages : 238
Appréciation reçue : 1
Inscrit le : 2 février 2016
Version d'Excel : 2013FR

Message par lauange » 23 novembre 2017, 09:37

pas mieux.
Excel 2013 windows et Excel 2016 Mac OSX
g
gui_29
Nouveau venu
Nouveau venu
Messages : 8
Inscrit le : 11 avril 2014
Version d'Excel : 2010 FR

Message par gui_29 » 23 novembre 2017, 09:54

C'est exactement le genre de formule que je cherchais, c'est parfait!

Les valeurs du premier onglet viennent d'un export et ne changeront jamais.

Merci beaucoup :D
Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message