ascenseur ou chariot Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
w
wall
Membre fidèle
Membre fidèle
Messages : 178
Inscrit le : 10 décembre 2014
Version d'Excel : 2010

Message par wall » 13 novembre 2017, 20:21

Bonsoir, Theze,
Je pense que je peux m'incliner au regard du résultat.
Je peux fermer le sujet avec mes respects bien sûr pour ce travail de minutie pour ne pas dire sorcier au risque de faire plaisir à Dhany.
Merci pour ce partage à vous tous
Cordialement
Wall ::D
T
Theze
Passionné d'Excel
Passionné d'Excel
Messages : 4'019
Appréciations reçues : 306
Inscrit le : 26 janvier 2011
Version d'Excel : 2007/2019

Message par Theze » 13 novembre 2017, 20:28

mais ça me fait plaisir que tu fasses plaisir à Dhany :D et bien sûr, je te remercie pour tes remerciements ::D
Il vaut mieux un qui sait que cent qui cherchent :wink:

Ce forum étant un lieu de partage, je n'accepte pas les messages privés !
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'910
Appréciations reçues : 693
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 13 novembre 2017, 20:39

Si, si, je confirme : vous m'avez fait bien plaisir, et merci d'avoir pensé à moi !  :wink:   :D
ravi que tu aies pu passer le sujet en résolu grâce à la solution de Theze:sp:
 
w
wall
Membre fidèle
Membre fidèle
Messages : 178
Inscrit le : 10 décembre 2014
Version d'Excel : 2010

Message par wall » 2 décembre 2017, 10:00

Bonjour à tous,
Je ré ouvre ce fil car j'ai une erreur avec le code. J'ai remarqué une erreur dans : .Comment.Text .Value Quand il n'y a pas de texte dans la C17, car en cliquant dessus, elle affiche une erreur dans comment.text. D'autres part, malgré l'absence du texte, un commentaire du texte absent ou supprimé s'affiche en survolant C17 (texte fantôme). Bizarre !
Auriez vous une solution?
Merci d'avance
Cordialement
chariotV6-3.xlsm
(26.24 Kio) Téléchargé 8 fois
T
Theze
Passionné d'Excel
Passionné d'Excel
Messages : 4'019
Appréciations reçues : 306
Inscrit le : 26 janvier 2011
Version d'Excel : 2007/2019

Message par Theze » 2 décembre 2017, 12:32

Bonjour,

Il te faut enlever la protection de la feuille !
Les commentaires n'acceptent que du String donc, si il y a un risque de valeurs numériques, il faut convertir :
.Comment.Text CStr(.Value)
Il vaut mieux un qui sait que cent qui cherchent :wink:

Ce forum étant un lieu de partage, je n'accepte pas les messages privés !
w
wall
Membre fidèle
Membre fidèle
Messages : 178
Inscrit le : 10 décembre 2014
Version d'Excel : 2010

Message par wall » 2 décembre 2017, 12:49

Bonsoir à tous,
Auriez vous une idée d'ou vient le 0 qui s'affiche sur la c17; sur le commentaire aussi ?
Merci encore
Cordialement
chariotV6-5.xlsm
(26.11 Kio) Téléchargé 5 fois
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'910
Appréciations reçues : 693
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 2 décembre 2017, 23:58

Bonsoir wall,

Ton 0 viens de ta formule en C17 : =Feuil2!C1 alors que C1 est vide ;
solution : nouvelle formule en C17 : =SI(Feuil2!C1="";"";Feuil2!C1)

Mais bien sûr, il faut changer le format : Standard au lieu de Texte
pour que la formule puisse être interprétée ! n'oublie pas de faire,
en C17, F2 et Entrée après mise en format Standard !


⚠  Effacer le commentaire de C17 pour que le 0 n'apparaisse plus !

Je te retourne ton fichier modifié :
chariotV6-5.xlsm
(25.39 Kio) Téléchargé 7 fois
⚠  Je ne suis pas sûr que ça sera bon, alors vérifie bien tout !

Cordialement,
dhany
 
w
wall
Membre fidèle
Membre fidèle
Messages : 178
Inscrit le : 10 décembre 2014
Version d'Excel : 2010

Message par wall » 3 décembre 2017, 08:31

Bonjour dhany, salut à tous,
J'ai fait des essais et cela fonctionne comme je souhaite sur le fichier joint. La formule est fonctionnelle, par contre sur mon fichier projet, j'ai une autre formule qui affiche 0. Elle est modifiable ou pas ? Merci
=INDEX(Feuil2!$Q$4:$Q$99;Graph!$D$1)
Cordialement
Avatar du membre
dhany
Passionné d'Excel
Passionné d'Excel
Messages : 6'910
Appréciations reçues : 693
Inscrit le : 3 octobre 2017
Version d'Excel : 2007 FR

Message par dhany » 4 décembre 2017, 04:37

Bonjour wall,

Pour enlever ton 0, la solution serait la même que pour ton autre formule :

=SI(INDEX(Feuil2!$Q$4:$Q$99;Graph!$D$1)=0;"";INDEX(Feuil2!$Q$4:$Q$99;Graph!$D$1))

Je dis « serait » car vu la longueur de la formule juste pour éviter l'affichage d'un 0,
ça vaut pas l'coup, et c'est mieux d'laisser la formule actuelle ; utilise plutôt un de
ces formats personnalisés :

"# ###0;-# ###0;" : affichage des nombres positifs et négatifs sans affichage du 0 (; final !)
"# ###0;;" : affichage des nombres positifs uniquement, ni les négatifs ni les 0 (;; final)

Les 2 formats ci-dessus sont avec un espace séparateur de milliers ; si tu n'en n'as pas
besoin, utilise plutôt : "0;-0;" ou "0;;" ; enfin, mets ,00 après le dernier 0 si tu veux des
nombres avec 2 chiffres après la virgule ; 2 exemples : "# ###0,00;-# ###0,00;"
et "0,00;;"

Cordialement
 
w
wall
Membre fidèle
Membre fidèle
Messages : 178
Inscrit le : 10 décembre 2014
Version d'Excel : 2010

Message par wall » 4 décembre 2017, 19:50

Bonsoir à tous,
Merci pour ta réponse, tout est ok
A bientôt
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message