Formule avec un onglet variable Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
C
Complay
Jeune membre
Jeune membre
Messages : 12
Appréciation reçue : 1
Inscrit le : 12 février 2020
Version d'Excel : 2016

Message par Complay » 14 février 2020, 09:44

Bonjours à vous !

J'ai plusieurs onglet (2017, 2018, 2019) avec un même tableau dedans pour chaque année.
Dans un onglet récapitulatif je voudrais avoir les données résumées de mes années pour chaque dossier.
Jusque là avec une simple recherchev, tout va bien. Cependant je voudrais que ça soit automatiser, c'est a dire que quand je créer un nouvel onglet pour une nouvelle année (2020) par exemple, je veux qu'en tirant mon tableau récapitulatif la formule aille chercher l'information dans l'onglet 2020.
J'ai créer un fichier avec mon problème pour que ce soit plus explicatif ::D .
J'ai essayer en remplaçant le 2017 de ma formule par '&B1&' mais ça ne marche pas.

Merci à vous et bonne journée.
Onglet variable.xls
(33 Kio) Téléchargé 4 fois
m
m3ellem1
Membre impliqué
Membre impliqué
Messages : 1'503
Appréciations reçues : 123
Inscrit le : 18 décembre 2018
Version d'Excel : 2016

Message par m3ellem1 » 14 février 2020, 09:50

Salut Complay,

à tester
=SOMMEPROD((INDIRECT("'"&$B$1&"'!$A$2:$A$11")=$A$1)*(INDIRECT("'"&$B$1&"'!$B$1:$F$1")=A2)*(INDIRECT("'"&$B$1&"'!$B$2:$F$11")))
Onglet variable_v1.xls
(35.5 Kio) Téléchargé 2 fois
@++
C
Complay
Jeune membre
Jeune membre
Messages : 12
Appréciation reçue : 1
Inscrit le : 12 février 2020
Version d'Excel : 2016

Message par Complay » 14 février 2020, 11:18

Bonjour,

Non ça ne marche pas.
Moi je voudrais qu'à la place de ma formule :
=RECHERCHEV($A$1;'2017'!A2:$F$11;2;0)

J'arrive à :
=RECHERCHEV($A$1;'B1$'!A2:$F$11;2;0)
Pour que ça aille chercher dans la feuille qui porte le nom de la cellule.

Merci
m
m3ellem1
Membre impliqué
Membre impliqué
Messages : 1'503
Appréciations reçues : 123
Inscrit le : 18 décembre 2018
Version d'Excel : 2016

Message par m3ellem1 » 14 février 2020, 11:30

 RECHERCHEV($A$1;'INDIRECT("'"&$B$1&"'! A2:$F$11);2;0)
C
Complay
Jeune membre
Jeune membre
Messages : 12
Appréciation reçue : 1
Inscrit le : 12 février 2020
Version d'Excel : 2016

Message par Complay » 14 février 2020, 11:44

La formule ne marche pas avec en message d'erreur :
Nous avons rencontrer une erreur dans cette formule
m
m3ellem1
Membre impliqué
Membre impliqué
Messages : 1'503
Appréciations reçues : 123
Inscrit le : 18 décembre 2018
Version d'Excel : 2016

Message par m3ellem1 » 14 février 2020, 12:20

Sorry,

essaie comme ca
=RECHERCHEV($A$1;INDIRECT($B$1&"!$A$2:$F$11");2;0)
C
Complay
Jeune membre
Jeune membre
Messages : 12
Appréciation reçue : 1
Inscrit le : 12 février 2020
Version d'Excel : 2016

Message par Complay » 14 février 2020, 12:44

Super merci ! Ca marche

Bonne journée
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message