Addition selon plusieurs critères Le sujet est résolu

Y compris Power BI, Power Query et toute autre question en lien avec Excel
M
Maxime19
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 9 octobre 2019
Version d'Excel : 2016 FR

Message par Maxime19 » 9 octobre 2019, 17:14

::o Bonjour à tous, après une grosse recherche sans résultat, je me permet de venir ici vous posez directement la question.
Jai un tableau comprenant plusieurs colonnes, la première une date, la deuxième un chiffre et je souhaite que dans ma 3ème colonnes s'affiche une date selon les critères de ma 2eme.
Si dans ma 2eme colonne:
__le chiffre est 1, je veux la date de la 1ère colonnes + 2ans
__le chiffre est 2, je veux la date de la 1ère colonnes +1ans
__le chiffre est 3, je veux la date de la 1ère colonnes à l'identique.
Je vous remercie d'avance.
Avatar du membre
curulis57
Membre impliqué
Membre impliqué
Messages : 2'934
Appréciations reçues : 106
Inscrit le : 4 janvier 2016
Version d'Excel : 2013 FR

Message par curulis57 » 9 octobre 2019, 18:24

Salut Maxime,

pas bien cherché...
=SI(B2=3;A2;SI(B2=1;DATE(ANNEE(A2) + 2; MOIS(A2); JOUR(A2));DATE(ANNEE(A2) +1; MOIS(A2); JOUR(A2))))
Serait pas plus malin d'incrémenter d'1 an si [B2]=1 et de 2 si [B2]=2 ?
Jamais d'autre possibilité que 1,2 ou 3 car, sinon, ce cas n'est pas prévu par la formule... ou plutôt si : incrémentation d'1 an...

8-)
A+
1 membre du forum aime ce message.
T
Theze
Passionné d'Excel
Passionné d'Excel
Messages : 3'836
Appréciations reçues : 279
Inscrit le : 26 janvier 2011
Version d'Excel : 2007

Message par Theze » 9 octobre 2019, 18:26

Bonjour,

Une piste : =DATE(ANNEE(A1)+CHOISIR(B1;2;1;0);MOIS(A1);JOUR(A1))
Ta date en A1, ton chiffre en B1 et la formule en C1. Tu tires vers le bas aussi loin que tu as des dates et chiffres !
1 membre du forum aime ce message.
Il vaut mieux un qui sait que cent qui cherchent :wink:

Ce forum étant un lieu de partage, je n'accepte pas les messages privés !
t
tulipe_4
Passionné d'Excel
Passionné d'Excel
Messages : 8'190
Appréciations reçues : 180
Inscrit le : 1 janvier 2011
Version d'Excel : 2000 2007

Message par tulipe_4 » 9 octobre 2019, 18:49

bonjour
une contribution
=DATE(ANNEE(A2)+(3-B2);MOIS(A2);JOUR(A2))
cordialement
1 membre du forum aime ce message.
c'est en cherchant qu'on trouve
n
njhub
Membre impliqué
Membre impliqué
Messages : 1'086
Appréciations reçues : 56
Inscrit le : 5 juin 2017
Version d'Excel : LO CALC 6.1.4.2 261218 FR-YT

Message par njhub » 9 octobre 2019, 20:34

Bonjour Maxime19, le forum

Autres possibilités
=MOIS.DECALER(A1;CHOISIR(B1;2;1;0)*12)
ou encore
=MOIS.DECALER(A1;(3-B1)*12)
1 membre du forum aime ce message.
M
Maxime19
Nouveau venu
Nouveau venu
Messages : 2
Inscrit le : 9 octobre 2019
Version d'Excel : 2016 FR

Message par Maxime19 » 10 octobre 2019, 10:22

Merci à tous pour vos réponses dans des délais aussi court. Ça m'a été d'une grande aide.
Du coup j'ai essayé toute vos solutions et tout est bien nickel.
Merci encore pour le temps que vous m'avez consacrer.
Bonne continuation à tous
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message