Fonction IFS?

Y compris Writer et toute autre question en lien avec les suites bureautiques Open Source
p
pierb
Jeune membre
Jeune membre
Messages : 10
Inscrit le : 1 mars 2016
Version d'Excel : 2007

Message par pierb » 9 septembre 2016, 15:28

Bonjour a tous,

J'ai un fichier excel dans lequel je voudrais avoir un texte apparaissant en colonne F en fonction du resultat de 2 cellules (colonnes B et D).

Colonne B = valeur en euros
Colonne D = 130/132 correspond au type de vente

Selon la valeur en B et le type de vente en D,

Nous aurions en colonne F l'un de texte suivant:

1 - 130 value above 2000 EUR
2 - 130 between 1000-2000EUR
3 - 130 value below 1000 EUR
1 - 132 value above 2000 EUR
2 - 132 value between 1000-2000 EUR
3 - 132 value below 1000 EUR

Auriez vous une idee de la formule permettant d'obtenir cela?

Pierre
Function IFS.xlsx
(9.29 Kio) Téléchargé 41 fois
Avatar du membre
mbbp
Passionné d'Excel
Passionné d'Excel
Messages : 6'344
Appréciations reçues : 234
Inscrit le : 29 mars 2014
Version d'Excel : 2007 FR

Message par mbbp » 9 septembre 2016, 18:58

Bonjour le forum,

F2 :
=SI(B2>2000;'Priority action'!$A$2;SI(B2>1000;'Priority action'!$A$3;SI(B2<=1000;'Priority action'!$A$4)))
m
mdo100
Membre dévoué
Membre dévoué
Messages : 698
Appréciations reçues : 16
Inscrit le : 25 mai 2013
Version d'Excel : 2010 FR

Message par mdo100 » 11 septembre 2016, 06:53

Bonjour pierb, mbbp,

Si c'est toujours d'actualité, voir si cela convient.
En "F2":
=SI(ET(D2=130;B2>2000);'Priority action'!A$2;SI(ET(D2=132;B2>2000);'Priority action'!A$5;SI(ET(D2=130;B2>1000);'Priority action'!A$3;SI(ET(D2=132;B2>1000);'Priority action'!A$6;SI(ET(D2=130;B2<=1000);'Priority action'!A$4;SI(ET(D2=132;B2<=1000);'Priority action'!A$7;""))))))

Et tirer vers la bas.
Voir fichier.

Cordialement.
Function IFS V1.xlsx
(14.82 Kio) Téléchargé 35 fois
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message