Calcul jour férié et dimanche (heure)

Y compris Writer et toute autre question en lien avec les suites bureautiques Open Source
U
Utilisateur55
Jeune membre
Jeune membre
Messages : 29
Inscrit le : 4 juin 2019
Version d'Excel : 2010

Message par Utilisateur55 » 7 juin 2019, 14:32

Bonjour, j'aimerai avoir mon calcul d'heure de jour fériés et dimanche dans la ligne "100%" il faudrait que si la date indique un jour férié (indiquer en 2e page) ou un dimanche le calcule se fasse tout seul.
je n'ai pas la formule alors j'attends votre aide :)
Merci d'avance
Pointage Zeendoc N.ods
(11.34 Kio) Téléchargé 4 fois
U
Utilisateur55
Jeune membre
Jeune membre
Messages : 29
Inscrit le : 4 juin 2019
Version d'Excel : 2010

Message par Utilisateur55 » 7 juin 2019, 15:36

le même fiché au format .xls (sans cellule fusionnée)
Pointage Zeendoc.xlsm
(14.3 Kio) Téléchargé 2 fois
n
njhub
Membre dévoué
Membre dévoué
Messages : 850
Appréciations reçues : 33
Inscrit le : 5 juin 2017
Version d'Excel : LO CALC 6.1.4.2 261218 FR-YT

Message par njhub » 7 juin 2019, 17:49

Bonjour,

Essayez avec la formule suivante:
=SI(ESTNUM(EQUIV(B$5;$Jour_fériés.$B$2:$B$14;0));E$3-B$3;TEMPSVAL("00:00"))
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 11'205
Appréciations reçues : 343
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 7 juin 2019, 18:24

Re,

Pour les lecteurs du Forum qui essayent de suivre ce fil...

https://forum.excel-pratique.com/viewtopic.php?f=2&t=125430&p=769793#p769793
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
U
Utilisateur55
Jeune membre
Jeune membre
Messages : 29
Inscrit le : 4 juin 2019
Version d'Excel : 2010

Message par Utilisateur55 » 11 juin 2019, 10:10

njhub a écrit :
7 juin 2019, 17:49
Bonjour,

Essayez avec la formule suivante:
=SI(ESTNUM(EQUIV(B$5;$Jour_fériés.$B$2:$B$14;0));E$3-B$3;TEMPSVAL("00:00"))
Ca me donne une valeur négative (-0.7083333)
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 11'205
Appréciations reçues : 343
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 11 juin 2019, 10:27

Il faudrait choisir un fil ... et s'y tenir ...

https://forum.excel-pratique.com/viewtopic.php?f=2&p=770493#p770493
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
U
Utilisateur55
Jeune membre
Jeune membre
Messages : 29
Inscrit le : 4 juin 2019
Version d'Excel : 2010

Message par Utilisateur55 » 11 juin 2019, 11:10

le problème du calcul des jours fériés se passe ici
Avatar du membre
James007
Fanatique d'Excel
Fanatique d'Excel
Messages : 11'205
Appréciations reçues : 343
Inscrit le : 30 août 2014
Version d'Excel : 2007 EN

Message par James007 » 11 juin 2019, 11:25

Utilisateur55 a écrit :
11 juin 2019, 11:10
le problème du calcul des jours fériés se passe ici
Sincèrement ... je ne comprends vraiment pas ta démarche ...!!! 8[]

Pour le même fichier ... avoir deux sujets distincts dans deux Forums différents :

Les Dimanches d'un côté ... et les Jours Fériés de l'autre ... c'est totalement incohérent ... ::(

A y perdre le très peu de Latin qui me reste ... :cry:
A+

:)

Quand on n’a qu’un marteau, tous les problèmes deviennent des clous…
U
Utilisateur55
Jeune membre
Jeune membre
Messages : 29
Inscrit le : 4 juin 2019
Version d'Excel : 2010

Message par Utilisateur55 » 11 juin 2019, 11:29

Non, le nouveau sujet, se passe bien ici, dimanche et jours fériés, c'est vous qui continuez de poster sur l'autre sujet :lole: le problème était résolu pour le passage d'horaire et de jour de nuit
n
njhub
Membre dévoué
Membre dévoué
Messages : 850
Appréciations reçues : 33
Inscrit le : 5 juin 2017
Version d'Excel : LO CALC 6.1.4.2 261218 FR-YT

Message par njhub » 11 juin 2019, 17:18

Effectivement quand l'heure de fin était inférieure à l'heure de début le résultat était négatif, c'est corrigé avec la formule ci-dessous
=SI(ESTNUM(EQUIV(B$5;$Jour_fériés.$B$2:$B$14;0));SI(B$3>E$3;(E$3+1)-B$3;E$3-B$3);TEMPSVAL("00:00"))
Répondre Sujet précédentSujet suivant
  • Sujets similaires
    Réponses
    Vues
    Dernier message