3926 résultats trouvés

par Pedro22
21 avril 2020, 11:38
Forum : Excel - VBA
Sujet : Formule pour trouver un mot d'une phrase dans une cellule
Réponses : 10
Vues : 42161

Re: Formule pour trouver un mot d'une phrase dans une cellule

Bonjour, Un nouveau sujet dédié aurait été plus adapté ! Lorsque la cellule contient le mot cherché ainsi que d'autres caractères, on peut s'aider du caractère générique *. Il remplace la présence de n'importe quel caractère, en quantité indéfinie. Intégré dans une formule : =SI(NB.SI(A1;"*assiette*...
par Pedro22
20 avril 2020, 16:39
Forum : Excel - VBA
Sujet : Compter le nombre de décimale d'un nombre
Réponses : 15
Vues : 204

Re: Compter le nombre de décimale d'un nombre

Bonjour tout le monde ! Split découpe une chaîne de caractères en sous-chaînes selon un séparateur donné, par exemple , . Le résultat est une variable tableau. Exemple : Sub Démo() NombreTexte = "0,12" TableauResultat = Split(NombreTexte, ",") MsgBox "Partie entière = " & TableauResultat(0) MsgBox "...
par Pedro22
16 avril 2020, 10:38
Forum : Calc
Sujet : Somme sous open office
Réponses : 2
Vues : 113

Re: Somme sous open office

Bonjour,

La formule est bonne, c'est juste que les nombres (de pommes) ne sont pas reconnus comme tels, mais stockés sous forme de texte. En passant par une plage intermédiaire pour les convertir en nombre, ça devrait fonctionner.

Exemples de formules de conversion :
=CNUM(C8)
=C8*1
par Pedro22
15 avril 2020, 13:45
Forum : Excel - VBA
Sujet : Sauf un paramètre !
Réponses : 5
Vues : 36

Re: Sauf un paramètre !

Bonjour,

"Différent de" s'écrit : <>

La formule est donc :
=SOMME.SI.ENS($D$4:$D$17;$E$4:$E$17;"<>f")
On peut aussi faire référence à une cellule dont on modifie le contenu :
=SOMME.SI.ENS($D$4:$D$17;$E$4:$E$17;"<>"&$G$7)
par Pedro22
30 mars 2020, 16:34
Forum : Excel - VBA
Sujet : Calcul d'un taux de réussite en fonction d'une date
Réponses : 9
Vues : 76

Re: Calcul d'un taux de réussite en fonction d'une date

NB.SI.ENS() compte le nombre de lignes d'une plage qui respectent un ensemble de conditions. Dans le cas présent, on compte le nombre de ligne comprise entre une date de début et de fin de mois. Ensuite, on ajoute une condition supplémentaire pour les montants positifs pour la seconde formule. Voilà...
par Pedro22
30 mars 2020, 15:49
Forum : Excel - VBA
Sujet : Calcul d'un taux de réussite en fonction d'une date
Réponses : 9
Vues : 76

Re: Calcul d'un taux de réussite en fonction d'une date

PS : En ajoutant une colonne binaire à votre premier tableau (1 pour positif, 0 le cas échéant), vous pouvez aussi utiliser un TCD (bien plus simple d'utilisation !) pour faire ces stats. Il est possible de faire des taux de réussite par mois (date groupées par année + mois) en faisant la moyenne de...
par Pedro22
30 mars 2020, 15:47
Forum : Excel - VBA
Sujet : Calcul d'un taux de réussite en fonction d'une date
Réponses : 9
Vues : 76

Re: Calcul d'un taux de réussite en fonction d'une date

Est-ce plus clair ? :) Oui ! J'ai changer vos formules dans le second tableau. B3 : 01/01/2020 affiché au format personnalisé mmmm puis en B4 et + : =MOIS.DECALER(B3;1) C3 : =NB.SI.ENS(Feuil1!$C$3:$C$12;">="&$B3;Feuil1!$C$3:$C$12;"<"&MOIS.DECALER($B3;1)) D3 : =SIERREUR(NB.SI.ENS(Feuil1!$C$3:$C$12;"...
par Pedro22
30 mars 2020, 15:20
Forum : Excel - VBA
Sujet : Calcul d'un taux de réussite en fonction d'une date
Réponses : 9
Vues : 76

Re: Calcul d'un taux de réussite en fonction d'une date

Désolé... En prenant l'exemple du mois de Mai il y a 3 opérations effectuées sur ce mois (2 négatives et 1 positive), je souhaiterais donc connaitre le taux de réussite du mois de Mai par rapport à ces résultats. Merci ! C'est surement limpide pour vous... Mais vous ne définissez toujours pas le ta...
par Pedro22
30 mars 2020, 15:13
Forum : Excel - VBA
Sujet : Calcul d'un taux de réussite en fonction d'une date
Réponses : 9
Vues : 76

Re: Calcul d'un taux de réussite en fonction d'une date

Bonjour,

Vous omettez un détail crucial... Il sort d'où ce taux de réussite ? En clair : à partir de quoi et comment le calcule-t-on ?
par Pedro22
26 mars 2020, 10:44
Forum : Excel - VBA
Sujet : Couleur de text dans cellule avec fonction
Réponses : 14
Vues : 127

Re: Couleur de text dans cellule avec fonction

oui j'avais pensé à cette idée d'ajouter plusieurs siècles, mais cela ne me plait pas, pas très élégant. j'ai pensé à mettre une condition dans MFC un test savoir si la cellule est formule avec =lire.cellule(48;x) mais je ne sait pas si cette fonction marche pour excel 2003? que pense tu de cette i...