3011 résultats trouvés

par M12
11 février 2020, 10:29
Forum : Excel - VBA
Sujet : Entrer une valeur dans une case pour faire apparaître d'autres données
Réponses : 8
Vues : 43

Re: Entrer une valeur dans une case pour faire apparaître d'autres données

Re,

Comme c'est une formule matricielle et que tu ne connais pas les fonctions Index() et Equiv()
le mieux est de faire un petit montage et de placer tes deux classeurs en lien
par M12
11 février 2020, 10:28
Forum : Excel - VBA
Sujet : Mise en forme conditionnelle utilisant une formule
Réponses : 8
Vues : 62

Re: Mise en forme conditionnelle utilisant une formule

Re,

Pour un forum de traitement d'image, il faut aller sur un forum qui traite les images
Ici, on traite les fichiers EXCEL :wink:
par M12
11 février 2020, 10:09
Forum : Excel - VBA
Sujet : Mise en forme conditionnelle utilisant une formule
Réponses : 8
Vues : 62

Re: Mise en forme conditionnelle utilisant une formule

Bonjour,

Avec un petit classeur exemple sans données confidentielles ressemblant à l'original, le travail sera facilité. ;;)
par M12
11 février 2020, 09:54
Forum : Excel - VBA
Sujet : Entrer une valeur dans une case pour faire apparaître d'autres données
Réponses : 8
Vues : 43

Re: Entrer une valeur dans une case pour faire apparaître d'autres données

Re,

Qu'entends tu par autre fichier (un autre onglet ou feuille) ou un autre classeur ?

Si c'est un autre classeur, il faudra modifier le lien, (d'INDEX et d'EQUIV) et de plus le classeur devra-être ouvert.
par M12
11 février 2020, 09:37
Forum : Excel - VBA
Sujet : Entrer une valeur dans une case pour faire apparaître d'autres données
Réponses : 8
Vues : 43

Re: Entrer une valeur dans une case pour faire apparaître d'autres données

Bonjour,

Inutile de tirer un tableau jusqu'à la fin
Les formules se recopient automatiquement sur la ligne suivante en étant sur la dernière colonne . Avec la touche TAB, la nouvelle ligne se créée avec la ou les formules
Apparition de valeurs automatique.xlsx
(14.18 Kio) Téléchargé 2 fois
par M12
11 février 2020, 09:18
Forum : Excel - VBA
Sujet : Problème de mise automatique de bordures
Réponses : 4
Vues : 49

Re: Problème de mise automatique de bordures

Bonjour,

A tester ( mais il y a du tri à faire dans les macros) :?
Travail 2 (1).xlsm
(74.73 Kio) Pas encore téléchargé
Edit: Bonjour James, pas vu ta réponse :wink:
par M12
11 février 2020, 07:56
Forum : Excel - VBA
Sujet : Erreur de formule
Réponses : 3
Vues : 34

Re: Erreur de formule

Re,

Pourtant, je t'ai remis ton classeur modifié :lol:
Si tu ne fige pas la plage de ta "Matrice", c'est sûr que ça va marcher beaucoup moins bien
=RECHERCHEV(A7;MATRICE!$A$2:$G$104;4;FAUX)
par M12
11 février 2020, 07:26
Forum : Excel - VBA
Sujet : Erreur de formule
Réponses : 3
Vues : 34

Re: Erreur de formule

Bonjour, l'argument "Valeur_proche" a été omis. TABLE PRODUCTION.xlsx =RECHERCHEV(cellule_lue ; tableau ; numéro_de_colonne ; valeur_proche ) L'argument valeur_proche peut prendre deux valeurs : VRAI ou FAUX. Si l'argument est VRAI (ou 1), Excel prend la valeur inférieure la plus proche s'il ne trou...
par M12
11 février 2020, 06:29
Forum : Excel - VBA
Sujet : Formule INDIRECT
Réponses : 2
Vues : 30

Re: Formule INDIRECT

Bonjour, De mon côté, la formule d'origine a une erreur =SI(ESTVIDE('Feuille1'!F17));"";SOMME('Feuille1'!F17:F152)/nb_de_jour) correction =SI(ESTVIDE(Feuille1!F17);"";SOMME(Feuille1!F17:F152)/nb_de_jour) et la deuxième fonctionne parfaitement =SI(ESTVIDE(INDIRECT(A1&"!F17"));"";SOMME(INDIRECT(A1&"!F...
par M12
10 février 2020, 17:33
Forum : Excel - VBA
Sujet : Rechercher la derniÈre et l avant derniÈre date les plus ressentes
Réponses : 3
Vues : 49

Re: Rechercher la derniÈre et l avant derniÈre date les plus ressentes

Bonjour,

Un essai à voir avec formule matricielle
Classeur1 (25).xlsx
(10.74 Kio) Téléchargé 4 fois
FORMULE MATRICIELLE
Appuyer sur les touches : Ctrl+Maj+entrée pour valider.
Des crochets apparaissent de part et d'autre de la fonction dans le champs de la cellule : {}