3230 résultats trouvés

par M12
11 mai 2020, 09:51
Forum : Excel - VBA
Sujet : SI case vide alors mettre 0
Réponses : 6
Vues : 22

Re: SI case vide alors mettre 0

Bonjour

Il faudrait que le code mette un 0 dans les cases vides d'un tableau

Quel Code ? :(
par M12
11 mai 2020, 09:25
Forum : Excel - VBA
Sujet : Ajouter un message aprés éxécution VBA
Réponses : 2
Vues : 22

Re: Ajouter un message aprés éxécution VBA

Bonjour,

Juste après le END WITH, coller cette ligne
MsgBox "La demande à bien été envoyée."
par M12
11 mai 2020, 09:21
Forum : Excel - VBA
Sujet : Simplification de code
Réponses : 4
Vues : 31

Re: Simplification de code

Bonjour, Teste ceci Option Explicit Dim f As Worksheet Dim lgn&, i% Sub Enregistrer() Sheets("Suivi ODACS").Unprotect Password:="MDP" Set f = Sheets("Suivi ODACS") For i = 11 To 21 If Cells(i, "C").Value = "" Then MsgBox "Veuillez remplir tous les champs.", vbOKOnly + vbCritical Cells(i, "C").Select...
par M12
11 mai 2020, 07:18
Forum : Excel - VBA
Sujet : Copier des donnes vers une autre Feuille
Réponses : 9
Vues : 52

Re: Copier des donnes vers une autre Feuille

Bonjour,

Sans savoir où se trouve les données à transcrire, difficile de pouvoir aider

:joindre:
par M12
10 mai 2020, 11:08
Forum : Excel - VBA
Sujet : Code Erreur 424 sur la fonction CountIF
Réponses : 5
Vues : 32

Re: Code Erreur 424 sur la fonction CountIF

Bonjour,

Enlève le ". Select" dans ta ligne de Countif
par M12
10 mai 2020, 10:47
Forum : Excel - VBA
Sujet : Ne rien afficher si vide
Réponses : 1
Vues : 14

Re: Ne rien afficher si vide

Bonjour
A tester
=SI(B4="";"";DATEDIF(B4;AUJOURDHUI();"Y"))
par M12
10 mai 2020, 10:45
Forum : Excel - VBA
Sujet : Recherche d'une formule
Réponses : 4
Vues : 14

Re: Recherche d'une formule

Bonjour,

Avec un petit BONJOUR, cela serait mieux
Bref

A tester en F15 et à valider en matricielle
=INDEX($F$3:$F$14;MAX(SI($F$3:$F$14<>"";LIGNE(INDIRECT("1:"&LIGNES($F$3:$F$14))))))
par M12
8 mai 2020, 20:07
Forum : Excel - VBA
Sujet : Recherche approximative de texte
Réponses : 4
Vues : 43

Re: Recherche approximative de texte

Re
OUI

Le dictionnaire :lol:
par M12
8 mai 2020, 18:24
Forum : Excel - VBA
Sujet : Recherche approximative de texte
Réponses : 4
Vues : 43

Re: Recherche approximative de texte

Bonjour,

Teste comme ceci
Fonction recherche approximative.xlsx
(17.08 Kio) Téléchargé 10 fois
ou avec index et equiv
=SI(B3="";"";RECHERCHEV("*"&B3&"*";$E$3:$F$8;2;FAUX))
par M12
8 mai 2020, 17:33
Forum : Excel - VBA
Sujet : Problème de formule
Réponses : 11
Vues : 70

Re: Problème de formule

Bonjour,

Teste comme ceci
=SI(J4-35<0;0;J4-35-L4)