11069 résultats trouvés

par Steelson
30 janvier 2015, 04:17
Forum : Excel - VBA
Sujet : Chercher dans une cellule B le texte d'une plage de cellules
Réponses : 4
Vues : 249

Re: Chercher dans une cellule B le texte d'une plage de cell

Après avoir cherché une fonction matricielle compacte, j'en suis arrivé à la même conclusion qu'il fallait une fonction. Sur une plage nommé "villes" ... Function statut(cellule As Range) As String statut = "ok" For Each cetteville In Range("villes") If cellule.Value Like "*" & cetteville & "*" Then...
par Steelson
29 janvier 2015, 06:20
Forum : Excel - VBA
Sujet : [Aide Rapide] NB.SI / SOMME.SI à 2 Conditions
Réponses : 3
Vues : 209

Re: [Aide Rapide] NB.SI / SOMME.SI à 2 Conditions

sans objet (erreur de manip)
par Steelson
29 janvier 2015, 05:56
Forum : Excel - VBA
Sujet : [Aide Rapide] NB.SI / SOMME.SI à 2 Conditions
Réponses : 3
Vues : 209

Re: [Aide Rapide] NB.SI / SOMME.SI à 2 Conditions

Un bout defichier serait plus facile pour répondre concrètement.

2 écritures possibles : SOMME.SI.ENS ou SOMMEPROD
par Steelson
29 janvier 2015, 05:56
Forum : Excel - VBA
Sujet : [Aide Rapide] NB.SI / SOMME.SI à 2 Conditions
Réponses : 3
Vues : 209

Re: [Aide Rapide] NB.SI / SOMME.SI à 2 Conditions

=SOMMEPROD( (A2:A23="QA SUBTASKS") * (B2:B23="DONE") * (D2:D23) )
par Steelson
28 janvier 2015, 10:41
Forum : Excel - VBA
Sujet : formule
Réponses : 6
Vues : 91

Re: formule

Un peu bestial, je n'ai pas trouvé mieux.

En P6
=SI(F6=1;G$4;"")&SI(G6=1;G$4;"")&SI(H6=1;G$4;"")&SI(I6=1;J$4;"")&SI(J6=1;J$4;"")&SI(K6=1;J$4;"")&SI(L6=1;M$4;"")&SI(M6=1;M$4;"")&SI(N6=1;M$4;"")
à condition que la matrice soit renseignée comme sur ton exemple.

Cela ressemble au sudoku ?
par Steelson
28 janvier 2015, 06:30
Forum : Excel - VBA
Sujet : Tableaux des pertes
Réponses : 2
Vues : 104

Re: Tableaux des pertes

Tout simplement :
=SOMMEPROD((C3:C13)*(E3:E13))
si les produits vont de la ligne 3 à 13
par Steelson
28 janvier 2015, 05:59
Forum : Excel - VBA
Sujet : augmenter une somme de 100 euros chaque mois automatiquement
Réponses : 3
Vues : 340

Re: augmenter une somme de 100 euros chaque mois automatique

exemple avec un début au 1/1/2014
=DATEDIF("1/1/2014";AUJOURDHUI();"m")*100
par Steelson
27 janvier 2015, 13:16
Forum : Excel - VBA
Sujet : Importer un fichier CSV dans Excel sous VBA
Réponses : 2
Vues : 2137

Re: Importer un fichier CSV dans Excel sous VBA

Une solution :
Sub ouvrir_csv()
 
Nom_Fichier = Application.GetOpenFilename("Fichiers csv, *.csv")
If Nom_Fichier <> False Then
    Workbooks.OpenText Filename:=Nom_Fichier, Origin:=xlWindows, _
        StartRow:=1, DataType:=xlDelimited, Local:=True, Semicolon:=True
End If

End Sub
par Steelson
27 janvier 2015, 05:08
Forum : Excel - VBA
Sujet : Quel code pour ajouter un commentaire par double-clic ?
Réponses : 17
Vues : 935

Re: Quel code pour ajouter un commentaire par double-clic ?

Private Sub Worksheet_BeforeDoubleClick(ByVal Target As Range, Cancel As Boolean) Dim ajd As String ajd = Date textee = Target.Value & " " & InputBox("Commentaire") With Target If .Comment Is Nothing Then .AddComment (textee) End If SendKeys "%im" End With End Sub Superbe toto l'asticot ! Merci, c'...
par Steelson
27 janvier 2015, 04:48
Forum : Excel - VBA
Sujet : Convertir Heure en centième automatiquement
Réponses : 1
Vues : 2150

Re: Convertir Heure en centième automatiquement

Sheets("Feuil2").Cells(k, 2) = Split(.Cells(i, j), ":")(0) * 1 + Split(.Cells(i, j), ":")(1) / 60