2802 résultats trouvés

par R@chid
26 février 2020, 00:36
Forum : Excel - VBA
Sujet : Comptage distinct nouveaux clients
Réponses : 5
Vues : 103

Re: Comptage distinct nouveaux clients

Bonsoir @ tous, une question subsidiaire et j'espère vraiment qu'elle ne soit pas bête. Si un client est déjà présent pour la réf4 dans en janvier, et je le trouve présent pour la réf3 pour en février, je le compte comme nouveau client ou non ? Si tu peux mettre les résultats escomptés sur le fichie...
par R@chid
24 février 2020, 16:49
Forum : Excel - VBA
Sujet : Première valeur non nulle dans matrice avec coordonnées
Réponses : 17
Vues : 113

Re: Première valeur non nulle dans matrice avec coordonnées

Re,
on a des pseudos, merci de les utiliser pour bien nous préciser à qui tu adresses la parole.

@ te relire
par R@chid
24 février 2020, 15:30
Forum : Excel - VBA
Sujet : Affichage de mois
Réponses : 4
Vues : 51

Re: Affichage de mois

Re,
en F8 :
=SI(OU(MOD(COLONNES($F:F)-1;2)=1;MOIS($D8+ENT((COLONNES($F:F)-1)/2)+1)<>MOIS($D8));"";$D8+ENT((COLONNES($F:F)-1)/2)+1)
@ tirer vers la droite


Cordialement
par R@chid
24 février 2020, 15:25
Forum : Excel - VBA
Sujet : Première valeur non nulle dans matrice avec coordonnées
Réponses : 17
Vues : 113

Re: Première valeur non nulle dans matrice avec coordonnées

Re,
ok
=SI(RECHERCHEV(B5;D4:J20;EQUIV(B3;D3:J3;0);0)=0;PETITE.VALEUR(DECALER(D4:D20;;EQUIV(B3;E3:J3;0));NB.SI(DECALER(D4:D20;;EQUIV(B3;E3:J3;0));"<=0")+1);RECHERCHEV(B5;D4:J20;EQUIV(B3;D3:J3;0);0))
Casse-Tete_V3.xlsx
(14.27 Kio) Téléchargé 2 fois

Cordialement
par R@chid
24 février 2020, 14:33
Forum : Excel - VBA
Sujet : Affichage de mois
Réponses : 4
Vues : 51

Re: Affichage de mois

Bonjour,
oui c'est possible si tu peux joindre un fichier exemple pour voir ce que tu as et comment nous pourrons t'aider.

Cordialement
par R@chid
24 février 2020, 14:30
Forum : Excel - VBA
Sujet : Première valeur non nulle dans matrice avec coordonnées
Réponses : 17
Vues : 113

Re: Première valeur non nulle dans matrice avec coordonnées

Re, C'est pas encore le résultat escompté mais c'est déjà impressionnant. Avec ta formule, quand il ne trouve pas de résultat dans la cellule il va chercher directement le dernier prix de la colonne. Or, je voudrais qu'il aille chercher non pas le dernier tout en bas, mais plutôt le premier non nul ...
par R@chid
24 février 2020, 13:24
Forum : Excel - VBA
Sujet : Première valeur non nulle dans matrice avec coordonnées
Réponses : 17
Vues : 113

Re: Première valeur non nulle dans matrice avec coordonnées

Bonjour,
une proposition par formule :
=SI(RECHERCHEV(B5;D4:J20;EQUIV(B3;D3:J3;0);0)&""="";DECALER(D3;EQUIV(9^9;DECALER(D4:D20;;EQUIV(B3;E3:J3)));EQUIV(B3;E3:J3;0));RECHERCHEV(B5;D4:J20;EQUIV(B3;D3:J3;0);0))

Cordialement
par R@chid
24 février 2020, 13:07
Forum : Excel - VBA
Sujet : Trouver une valeur en fonction d'un matricule et d'une date
Réponses : 3
Vues : 42

Re: Trouver une valeur en fonction d'un matricule et d'une date

Bonjour @ tous,
:bv:
en C3 :
=SOMME.SI.ENS(Export!$C:$C;Export!$A:$A;$A3;Export!$B:$B;C$2)
@ tirer vers le bas et vers la droite


Cordialement
par R@chid
23 février 2020, 14:56
Forum : Excel - VBA
Sujet : Filtre avancé
Réponses : 5
Vues : 50

Re: Filtre avancé

Re, 18 critères ?! Si tu peux donner un exemple concret de ton fichier je pourrai peut-être te le refaire d'une autre manière. Est-ce que t'as toujours 2 lignes à comparer entre elles, ou ça change et ça peut aller jusqu'à 18 lignes? Ou bien t'as 18 critères que tu vas combiner 2 à chaque itération ...
par R@chid
23 février 2020, 13:58
Forum : Excel - VBA
Sujet : Filtre avancé
Réponses : 5
Vues : 50

Re: Filtre avancé

Re,
Le filtre natif d'Excel ne peut pas te faire ce que tu souhaites, sauf si un VBAiste passe par là pour te faire une Macro.
Je te propose une solution par colonne intermédiaire, à toi de l'adapter à ton besoin.
Voir PJ
ESOKEITH_V1.xlsx
(37.8 Kio) Téléchargé 4 fois

Cordialement