1606 résultats trouvés

par OOoiste
4 avril 2020, 13:49
Forum : Excel - VBA
Sujet : Concaténation de deux vecteurs
Réponses : 3
Vues : 41

Re: Concaténation de deux vecteurs

c
par OOoiste
2 avril 2020, 21:08
Forum : Excel - VBA
Sujet : Formule sommeprod
Réponses : 8
Vues : 95

Re: Formule sommeprod

Bonsoir,

Il faut tout simplement éviter le signe multiplicateur * en présence de texte.

La formule
=SOMMEPROD((K11:K22>=L9)*(K11:K22<=M9)*(L11:L22))
devient
=SOMMEPROD((K11:K22>=L9)*(K11:K22<=M9);L11:L22)

A+
par OOoiste
2 avril 2020, 11:08
Forum : Excel - VBA
Sujet : Prix moyen pondéré
Réponses : 5
Vues : 56

Re: Prix moyen pondéré

Bonjour,

Soit "quantité" la plage contenant les quantités reçues, et "prix" celle contenant les prix correspondants à ces quantités :
=SOMMEPROD(quantité;prix)/SOMME(quantité)
donne le prix moyen pondéré.

A+
par OOoiste
1 avril 2020, 21:10
Forum : Excel - VBA
Sujet : Calcul sur excel
Réponses : 3
Vues : 42

Re: Calcul sur excel

Bonsoir,
=MOD(TEXTE(A1;"JJMMAAAA")-1;9)+1
A+
par OOoiste
24 mars 2020, 21:10
Forum : Excel - VBA
Sujet : Dénombrement en ligne
Réponses : 14
Vues : 140

Re: Dénombrement en ligne

Bonsoir Juste pour dire que c'est possible par formule, même si c'est plus simple avec la macro. Il s'agit d'une formule matricielle, donc à valider par CTRL+MAJ+Entrée : =SI($A2=B$1;"";SOMME(FREQUENCE(SI(base!$A$1:$E$24=$A2;LIGNE(base!$A$1:$E$24));LIGNE(base!$A$1:$A$24))*FREQUENCE(SI(base!$A$1:$E$2...
par OOoiste
20 mars 2020, 21:21
Forum : Excel - VBA
Sujet : Répartition chiffre d'affaires par jour
Réponses : 8
Vues : 96

Re: Répartition chiffre d'affaires par jour

Bonsoir,

Pour l'écart, voir cellule D2.

A+
par OOoiste
19 mars 2020, 21:29
Forum : Excel - VBA
Sujet : Lister/ trier des combinaisons
Réponses : 3
Vues : 44

Re: Lister/ trier des combinaisons

Bonsoir,

Avec la nouvelle fonction FILTRE (excel 365) :
=FILTRE($A$2:$A$6;INDEX($B$2:$F$6;0;EQUIV($C$9;$B$1:$F$1;0))=COLONNES($B$11:B11))
A+
par OOoiste
18 mars 2020, 17:34
Forum : Excel - VBA
Sujet : Fonction FILTRE et validation de données
Réponses : 1
Vues : 48

Re: Fonction FILTRE et validation de données

Bonjour,

Bien que non validée matriciellement, il s'agit d'une fonction matricielle.
Et il n'est pas possible d'utiliser une formule matricielle comme validation de données dans Excel (à contrario de LibreOffice Calc).

A+
par OOoiste
6 janvier 2020, 17:08
Forum : Excel - VBA
Sujet : Faire correspondre des données dans excel
Réponses : 2
Vues : 48

Re: Faire correspondre des données dans excel

Bonjour,

Le problème vient du fait que les codes dans le rapport sont des valeurs numériques alors qu'elles sont en "texte" dans la base.

Pour contourner le problème il suffit de concaténer le nombre avec une chaine de texte nulle .
G2 → G2&""
=RECHERCHEV(G2&"";Données!$A$2:$B$67;2;FAUX)
A+
par OOoiste
6 janvier 2020, 10:32
Forum : Excel - VBA
Sujet : Format fraction dénominateur figé même si résultat > 1
Réponses : 3
Vues : 52

Re: Format fraction dénominateur figé même si résultat > 1

Bonjou J'ai sélectionné le format personnalisé #" "??/9 ... Auriez-vous s'il vous plait une solution pour que même au-delà de 1, Excel ne scinde pas en Nombre entier + fraction / 9 mais bien toujours en fraction / 9 uniquement ? Ton format personnalisé #" "??/9 signifie "nombre entier" (#), puis "es...